XIM Community

Xim Link/Belkin Cable issue , was working in the past  (Read 71 times)

Offline th3crusader

  • Member
  • *
  • Posts: 4
    • View Profile
My xim link and belkin cable have worked just fine in the past but as of recent I cannot get it to function. Right now I've got everything plugged in and set up correctly, and the xim manager app recognizes the transfer cable but Xim link and my pc wont acknowledge it. However, if I flip the way the USBs are plugged in (the end plugged into my computer and switch it with the end plugged into the Xim), the Xim manager will stop recognizing the cable, but my PC will notice it as plugged in. Furthermore the error in Xim link will switch from "no compatiable transfer cable connected" to the Xim apex not being able to connect or something. I'm not sure why it worked fine in the past, but is having these issues now. Maybe its because I left everything plugged in, but not in use for a long period of time? IDK

Offline Nataliy

  • Member
  • *
  • Posts: 327
  • I wish you a good day
    • View Profile
Re: Xim Link/Belkin Cable issue , was working in the past
« Reply #1 on: 12:53 AM - 11/26/21 »
It is very likely that the cable is out of order, check it on other equipment.

XIM4 + PS4 + CALL OF DUTY VANGUARD
https://clck.ru/YmnXp


Admin