XIM Community

[ACTIVE] My Xim is completely broken.  (Read 70 times)

Offline LordFarquaad00

  • Member
  • *
  • Posts: 2
    • View Profile
[ACTIVE] My Xim is completely broken.
« on: 12:17 AM - 11/24/21 »
I ordered a Xim a while ago and I havenít opened the box since it got here and I finally plugged it in yesterday and it did not work. I followed multiple tutorials on how to set it up and mine wonít even activate Iíve tried everything. Can I please receive a replacement?
« Last Edit: 10:01 AM - 11/24/21 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Re: My Xim is completely broken.
« Reply #1 on: 10:01 AM - 11/24/21 »
Welcome to the community. There's more than one cause for this but it's usually setup related and can be fixed. To help fix the problem can you please go through the list linked below and share the results from each step? This may also resolve the issue.

Some of the results will pass assuming that your non-XIM devices are working normally. If it does not resolve the problem then we can use the combined results from each numbered step to find a solution.

https://community.xim.tech/index.php?topic=61565.0
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline LordFarquaad00

  • Member
  • *
  • Posts: 2
    • View Profile
Re: [ACTIVE] My Xim is completely broken.
« Reply #2 on: Today at 12:48 AM »
I tried all these steps and it still doesnít work.


Admin