XIM Community

[ACTIVE] Xim Apex plugged in while controller updating now software broken  (Read 57 times)

Offline DEMON_Kron

  • Member
  • *
  • Posts: 1
    • View Profile
  • Gamertag: DEMON Kron
I have accidentally update my Xbox elite series 2 controller with xim apex plugged in now its everything broken when i press a button i also already did a factory reset and tried to install the update new or install a old update and try and then install new one and try nothing worked i guess the software is broken can anybody help me?
« Last Edit: 10:28 AM - 11/22/21 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Welcome to the community. The latest firmware in the download section doesn't support this update but it is supported by APEX's latest beta.

If you would like to test our latest beta please visit the link below. Please read the instructions on the download pages. Feedback in the beta section of the forum is appreciated.

https://xim.tech/beta
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos