XIM Community

[ACTIVE] No proper connection to ps4, tried pretty much everything  (Read 137 times)

Offline ShadyXV

  • Member
  • *
  • Posts: 4
    • View Profile

i just started using the XIM4 again and got major problems. When I connect it to the ps4 with controller, keyboard and mouse the iOS app shows all the connected peripherals but no button press on those is registered in the app when i try to assign keys or just press a button in the app menu. Also the controller connection isnt really passed through to the ps4 (it just flashes orange, pressing PS Button doesnt help, its set to connect via USB and is the proper model for usb connections)

So I tried updating the firmware to the latest version from 2020, this was already hard as no windows device I tried could connect via manager or firmware updater. So I went to Mac which worked first try. I plugged everything back in, started the PS4 and still the same problem, I tried restarting the ps4 several times and resetting the controllers (tried two different ones which already worked with xim4 before). Also the peripherals were working with the XIM4 a year ago, so it cannot be a compatability issue especially because the iOS app detects every device.

Im getting pretty frusttrated as I dont see any more options I can try to fix it, do you guys have an idea what I could do?

Thanks for your help

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58824
    • View Profile
Re: No proper connection to ps4, tried pretty much everything
« Reply #1 on: 09:34 AM - 10/13/21 »
The orange controller light should eventually turn off when it no longer needs to charge. The controller should actually charge directly with the console without XIM4 attached to reduce your setups power draw and avoid issues like this. It's odd that you Mac recognized your XIM4 and not your PC. I wonder if this could be a loose connection issue between XIM4 and it's cable. It may help to try using other data cables between XIM4 and console. Just don't swap your console cable with your controller cable.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos