XIM Community

[Q/A] Polling issue help please  (Read 105 times)

Offline FrankDucks

  • Member
  • *
  • Posts: 12
    • View Profile
  • Gamertag: FrankDucks
[Q/A] Polling issue help please
« on: 04:59 PM - 08/21/21 »
Hey, Iíve recently switched to 250hz no dramas with it, but now trying to change to 500hz, which Iíve used in the past as well as 1000hz with no issues.
Now ever now on 500hz I get the flashing purple and also got the error that mouse rate is too low. I have updated everything to latest firmware and checked polling on the mouse, tried different mouse, both are G502 one wireless and the old one wired.
Playing on series x. Using the Xbox one controller I always have also tried with series x controller seemed to still not work.
Thanks Iím advance!
« Last Edit: 09:11 AM - 08/23/21 by mist4fun »

Offline antithesis

  • MVP
  • *
  • Posts: 13562
    • View Profile
    • Mod Squad
Re: Polling issue help please
« Reply #1 on: 05:18 PM - 08/21/21 »
It sounds like your mouse is 250Hz with APEX at 500Hz. Make sure your mouse polling is 500Hz too, or 1000Hz. XIM APEX Response Rate cannot be higher than mouse polling.

A simpler approach is to leave the mouse at 1000Hz, then you have the freedom to swap between all XIM APEX Response Rates.

Another possibility is you're using a Cronus with your setup, which freaks out at higher than 250Hz with a XIM. Titan Two doesn't have this problem and supports all XIM APEX Response Rates.

For Series X controller compatibility, install the beta XIM APEX Firmware and Manager from https://xim.tech/beta. You may also need to update the Series X controller firmware on Xbox or PC.

Official Australian distributor for
XIM NEXUS, XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline FrankDucks

  • Member
  • *
  • Posts: 12
    • View Profile
  • Gamertag: FrankDucks
Re: Polling issue help please
« Reply #2 on: 05:24 PM - 08/21/21 »
Thanks heaps for the reply, I have already tried that and tested the mouse on the pc it was consistently polling higher than the 500. I donít know what else to do. I changed it after your comment on a vid suggesting use 500 with default sync as it works well on most games :)

Offline FrankDucks

  • Member
  • *
  • Posts: 12
    • View Profile
  • Gamertag: FrankDucks
Re: Polling issue help please
« Reply #3 on: 05:27 PM - 08/21/21 »
Omg, just realised I didnít read your whole reply (am on my phone) I set the Titan 2 to 250 to match when I changed that, I guess that could be the issue???? I feel like an idiot haha will try changing the polling on Titan to 500 as well and see if that helps.

Offline antithesis

  • MVP
  • *
  • Posts: 13562
    • View Profile
    • Mod Squad
Re: Polling issue help please
« Reply #4 on: 05:44 PM - 08/21/21 »
Set the mouse to 1000Hz, XIM to 500Hz and Titan two to either match the XIM with 500Hz Input & Output Polling Rate, or Automatic :)

Official Australian distributor for
XIM NEXUS, XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline FrankDucks

  • Member
  • *
  • Posts: 12
    • View Profile
  • Gamertag: FrankDucks
Re: Polling issue help please
« Reply #5 on: 07:00 PM - 08/21/21 »
Sorted! Thanks for the assist.


Admin