XIM Community

[ACTIVE] XIM APEX IS NOT RECOGNIZING MY CONTROLLER  (Read 35 times)

Offline aku-rigs

  • Member
  • *
  • Posts: 1
    • View Profile
  • PSN ID: aku-rigs
Hello everyone!

So just as sad as it reads on the title, somehow my apex broke, and it no longer recognizes my controller. I used the XIM for very little at the tops six months and very sporadically.

I don't know if this somehow could be relevant for troubleshooting. Alright, so when everything is connected through the XIM APEX, nothing turns on or gets recognized. It is like it somehow lost the capability of letting power through. The XIM starts and goes straight into my profile but no green lights on the starting.

I have tested the hub on my pc, and it works flawlessly, letting me plug and use multiple peripherals. I even connected the hub straight to the PS4, and the controller turns on with no problem. I read on here that connecting the controller directly to the XIM might work; however, nothing happens. I used two ps4 controllers while trying to figure out what was wrong and one x-box one controller. None worked, I tried the controllers on my PC, and they all work with no problem.

Is there anything else that I could try? If not, then what? Do I have to buy a whole new set? Or is there some sort of repair service available?


keyboard: Logitech G-513
mouse: Logitech G502


« Last Edit: 04:50 PM - 06/10/21 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 56573
    • View Profile
Re: XIM APEX IS NOT RECOGNIZING MY CONTROLLER
« Reply #1 on: 04:46 PM - 06/10/21 »
Welcome to the community and thanks for sharing the troubleshooting you've already done. It may help to try using APEX in other console ports, disconnect devices in the other USB port if needed.

Does APEX power your peripherals if they are attached individually and directly connected to APEX without the hub?
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos