XIM Community

I'm impressed  (Read 455 times)

Offline Subtlebandit

  • Member
  • *
  • Posts: 1
    • View Profile
I'm impressed
« on: 03:52 PM - 04/21/21 »
I just got a XIM Apex today and had to try it out on my lunch break. I'm trying to use it on PS5 (with a DS4 and PS4 games for now), so I was worried I might have some issues with the setup. It was pretty simple to setup, update firmware, and plugin.

When I plugged it all in the light would stay red (meaning the controller was not communicating?) so I tried troubleshooting for a few minutes. The controllers were pretty much dead, and maybe if I charged them. And I'm sure I can find more micro USB cables to try. But then I tried tapping the arrow keys and it was working, navigating the menu. 
 
The only games I had installed to try had updates to download, so I tried it with Conan Exiles offline. After I turned up the mouse sensitivity a bit everything worked better than I expected. It felt very natural, which I was expecting it to be a little clunky for some reason, forgive me. I was ready to put up with it but it feels great, I'm impressed.

I believe the light was red even while I was playing for a few minutes, but everything seemed fine. Excited to try it out more tonight  8)

Offline antithesis

  • MVP
  • *
  • Posts: 12432
    • View Profile
    • Mod Squad
Re: I'm impressed
« Reply #1 on: 04:07 PM - 04/21/21 »
Welcome to the community.

A red LED is the default colour for the selected game config, it's not an error code.

The LED colour can be changed by editing your game settings in XIM APEX Manager and can be used to indicate which game is currently loaded on XIM, e.g blue LED for Destiny 2, Green for Halo, Pink for Apex Legends etc.

Official Australian distributor for XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts


Admin