XIM Community

[ACTIVE] Xim Apex adapter not working/connecting  (Read 82 times)

Offline Teacher1

  • Member
  • *
  • Posts: 3
    • View Profile
[ACTIVE] Xim Apex adapter not working/connecting
« on: 06:50 AM - 10/18/20 »
I've tried looking through some of the threads in the forum to find fixes but not had any luck.

I've already update the firmware
I've connected only the controller to the adapter (controller vibrates but does not power on - the usb does not flash green and stays red) I've tried two different controllers and different power cables.

I've tried the mouse and keyboard on separate systems and they still work correctly.

Previous if I disconnected the keyboard and reconnected it this would sometimes fix the problem but even this isn't working anymore. Any help would be much appreciated.
« Last Edit: 12:27 PM - 10/18/20 by OBsIV »

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 38300
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Xim Apex adapter not working/connecting
« Reply #1 on: 12:27 PM - 10/18/20 »
Welcome to the community. Have you always had these issues, or, is this new? If you are connecting your controller to your XIM APEX directly (no hub), and you can't get the green initialization lights, then, that's were we need to focus to figure out what's going wrong.

Is this on Xbox One or PlayStation 4? If on Xbox, did you try hard rebooting your console? Also, if you press the Guide button on your controller, do you see things initialize correctly?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline Teacher1

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] Xim Apex adapter not working/connecting
« Reply #2 on: 02:48 PM - 10/18/20 »
Thanks for the reply. It's a problem that has only started occurring recently.

I'm on Xbox One. I tried a hard reset and this did not correct the issue.

I have just tried connect the controller to the usb directly and it has flashed green this time. I suspect the issue is with the usb hub? Are there options to purchase replacement ones?


Offline Teacher1

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] Xim Apex adapter not working/connecting
« Reply #3 on: 04:05 PM - 10/18/20 »
Figured out that the usb hub was the problem. Swapped it out for a separate usb hub and the it has corrected the problem. Thanks for your time and help

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 38300
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: [ACTIVE] Xim Apex adapter not working/connecting
« Reply #4 on: 06:35 PM - 10/18/20 »
Can you please connect the hub to your computer and test out all it's ports by plugging your mouse into each one and seeing if there are any problems?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.