XIM Community

[RESOLVED] Sony navigation - input delay on Division  (Read 80 times)

Offline Bash1066

  • Member
  • *
  • Posts: 5
    • View Profile
  • Gamertag: Bash1066
Hi guys and gals I'm having a problem with my Sony navigation analog stick, Recently it has been having input delay and I can't seem to fix it and I have updated the firmware and downloaded updates from the app I only play Division 1&2 I would appreciate it if anybody could help me. :)
« Last Edit: 09:05 AM - 07/30/20 by mist4fun »

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 30729
    • View Profile
Re: Sony navigation - input delay on Division
« Reply #1 on: 05:53 AM - 07/29/20 »
Hey and welcome to the forum,

when you say recently, do you mean that you havent had that delay previously? If so in what situations do you notice it the most and does the delay only affect your Sony Nav or also your mouse?
PS4 & X1 | C: MS | XIM4 | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Zowie EC1-A | D: 3200 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

My Fortnite Creator Code: beamimpact
Check out my Youtube Channel: XIMGameplay

Offline Bash1066

  • Member
  • *
  • Posts: 5
    • View Profile
  • Gamertag: Bash1066
Re: Sony navigation - input delay on Division
« Reply #2 on: 06:11 AM - 07/29/20 »
I've been using the nav for about a year now and it's just the nav not my mouse it keeps delaying on the movement and Ads.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54243
    • View Profile
Re: Sony navigation - input delay on Division
« Reply #3 on: 09:30 AM - 07/29/20 »
The Division is reported to have a weighty feel to it that could be interpreted as input delay but if you didn't have this issue before it's probably not the general feel of the game.

Could you describe how ADS is affected by this? About the Nav input delay, I take this as the analog stick isn't very responsive, possibly the buttons too? Could you please describe the issue in more detail?

In the meantime, the next time you notice this with the nav check the controller to see if it has the same problem. This can tell us if it's isolated to one peripheral or the whole system is being affected.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Bash1066

  • Member
  • *
  • Posts: 5
    • View Profile
  • Gamertag: Bash1066
Re: Sony navigation - input delay on Division
« Reply #4 on: 09:36 AM - 07/29/20 »
The controller is working fine when I aim down sight it doesn't instantly Ads it has  like a 1 second delay them aims down sight also when I try to move the cursor in the map it's has a big delay and ends up going crazy but all  other buttons are fine do you think I need a new nav and do you think the analog is broke.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54243
    • View Profile
Re: Sony navigation - input delay on Division
« Reply #5 on: 09:42 AM - 07/29/20 »
Has it always been like this? If this is a new problem try making a new config and test using default config settings. It would be worth checking that the in-game settings are default.

If the problem doesn't exist with the controller it's related to this nav in some way. I would try using the nav in wireless mode next. This removes a few nav related issues and it may help. To do this:

NAV off
XIM off
Controller in XIM Port 3 "..."
NAV in XIM Port 1 "."
XIM on
Connect manager and make sure NAV shows up
Unplug NAV
Confirm wireless NAV shows up in manager
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Bash1066

  • Member
  • *
  • Posts: 5
    • View Profile
  • Gamertag: Bash1066
Re: [ACTIVE] Sony navigation - input delay on Division
« Reply #6 on: 09:46 AM - 07/29/20 »
Okay I will test what you have said and will get back to you, And thank you for helping.

Offline Bash1066

  • Member
  • *
  • Posts: 5
    • View Profile
  • Gamertag: Bash1066
Re: [ACTIVE] Sony navigation - input delay on Division
« Reply #7 on: 06:52 AM - 07/30/20 »
I have done what you said and it's working now so thank you for helping me 😎👍

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54243
    • View Profile
Re: [ACTIVE] Sony navigation - input delay on Division
« Reply #8 on: 09:05 AM - 07/30/20 »
That's good to hear. If the wireless test helped them this tells us that there may be an issue with the nav itself, it's charge, or it's cable. You can continue to use it wirelessly or troubleshoot these three suggestions to use it in wired mode.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos