XIM Community

[ACTIVE] XIM APEX RANDOMLY DISCONNECTS  (Read 19 times)

Offline biagio.lembo

  • Member
  • *
  • Posts: 2
    • View Profile
  • Gamertag: I STEAMKILLER I
[ACTIVE] XIM APEX RANDOMLY DISCONNECTS
« on: 01:05 PM - 06/30/20 »
I purchased the Xim Apex almost one year ago. I used it with my Xbox One X and I played only one game: Apex Legends. Actually I currently have loaded only that one configuration (the one for Apex Legends).
I never experienced any issue, It played flawlessly & wonderfully.......... until now.

Two weeks ago the Xim began to act weirdly: It randomly disconnects all 3 peripherals connected to the Hub:

The original xbox controller (on port 3),
The sony nav controller (on port 2),
The Klim Veni mouse (on port 1).

When it does that all LEDs on these peripherals go off; only the Xim led stays blue as if nothing happened. At this point I can't move or do any action so I have to stand up and manually pull off the Xim from the console. If I put back the Xim in the usb port all systems go up again and I can play for an extra 10 minutes or maybe half hour... there is no way to predict how often it will repeat this nonsense.
I already read all threads regarding this issue so I tried to follow the suggestions I found (as for example I changed the xbox controller cord and the nav controller cord with new ones and I tried to plug in the xbox controller battery into the controller and charge it one hour before playing). no use.
I also thought that the hot summer could influence the functionality of the Xim so I pointed a fan on the console to supply fresh air. no use.
I'm kind of scared because this problem wasn't there at the beginning and now I can't get rid of it. I really hope you can help me with that.
« Last Edit: 04:36 PM - 06/30/20 by mist4fun »

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53975
    • View Profile
Re: XIM APEX RANDOMLY DISCONNECTS
« Reply #1 on: 04:36 PM - 06/30/20 »
If all that has changed is time it's probably just a battery. Try charging the nav directly with the console while XIM and hub are disconnected. Remove the controller battery as well before attempting to use the controller with XIM next. This might be enough to solve your issue.

If the above doesn't help then I would look toward the nav next, this is a common source of this issue for more than one reason. A good way to troubleshoot is to use the nav in wireless mode. If the issue does not happen in wireless mode we know that it's related to the nav in some way. Here's how to pair the nav:

NAV off
XIM off
Controller in XIM Port 3 "..."
NAV in XIM Port 1 "."
XIM on
Connect manager and make sure NAV shows up
Unplug NAV
Confirm wireless NAV shows up in manager
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos