XIM Community

[ACTIVE] Setup Issues  (Read 59 times)

Offline hanlonbrooks.m

  • Member
  • *
  • Posts: 3
    • View Profile
[ACTIVE] Setup Issues
« on: 07:56 AM - 06/29/20 »
Hi there,

I recently purchased my xim apex and am having issues setting it up with my Xbox. I have taken the following steps during setup and it is still not working.

1. Went through regular setup (couldn't get it to work)
2. Tested wires for controller (5 different wires)
3. Hard reset of xbox
3. Tested controller with Xim apex (green lights flash)
4. Attached hub to computer to test (mouse and keyboard port work, controller says unidentifiable when in computer)
5. Turned off backlit keyboard and lights on mouse
6. Tried moving xim to back of console

When looking at the Xim manager I am connected via Bluetooth to the Xim but it can't identify any of the wired connections to the Rtc. Any help would be greatly appreciated!
« Last Edit: 09:31 AM - 06/29/20 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53970
    • View Profile
Re: Setup Issues
« Reply #1 on: 09:31 AM - 06/29/20 »
Welcome to the community and thank you for sharing your troubleshooting info. I'll need a bit more info to know if the controller is working correctly.

Quote
3. Tested controller with Xim apex (green lights flash)

Just to verify, by green lights flash do you mean that you see 4 green lights flash in a row during the startup sequence? There is another green light in the sequence but the 4 flashes in a row are what's needed.

Quote
4. Attached hub to computer to test (mouse and keyboard port work, controller says unidentifiable when in computer)

Does the controller work when connected directly to the computer without XIM and hub? Or when the hub only has the controller attached to it and then is connected to the PC?

Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline hanlonbrooks.m

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] Setup Issues
« Reply #2 on: 10:09 AM - 06/29/20 »
Yea the sequence of green lights flashing happens when the controller is plugged in directly to the Xim apex.

Yea the controller works when connected directly to the computer without the Xim hub.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53970
    • View Profile
Re: [ACTIVE] Setup Issues
« Reply #3 on: 04:40 PM - 06/29/20 »
Thanks for verifying. Assuming you're using port 3, this is the controller's preferred port, try connecting the controller to port 1 or 2 of the hub if you haven't yet. Try to do this before APEX is started because once the controller is disconnected while APEX is on it can't re authenticate without restarting APEX.

It may help to start APEX with only the controller attached to the hub. If you notice the controller authenticate with APEX via the 4 green lights then connect the mouse and keyboard next.

Otherwise, because the hub works with a PC and the controller authenticates without the hub this tells us that there may be an issue with either the hub or APEX's port. One of these does not like the other. Do you have access to another hub? If so it will be helpful to know if the problem happens with a second hub.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline hanlonbrooks.m

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] Setup Issues
« Reply #4 on: 05:34 PM - 06/29/20 »
I've tried connecting the controller to the different ports and starting with only the controller connected but it hasn't worked either. I continue to get the green flashes when the controller is plugged directly into the apex port though.

Unfortunately I don't have another hub. Is there a specific type of hub that is required, I can purchase one if I have to.


Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53970
    • View Profile
Re: [ACTIVE] Setup Issues
« Reply #5 on: 09:19 AM - 06/30/20 »
APEX supports USB 2.0 hubs but 3.0 hubs are reported to work as well. If you have LED peripherals I recommend considering a hub that includes a power adapter. They can be a few dollars more and it may help with stability in the future.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos


Admin