XIM Community

[ACTIVE] XIM4 + Dualshock 4 : suddenly stopped working  (Read 41 times)

Offline sentryomega

  • Member
  • *
  • Posts: 1
    • View Profile
  • PSN ID: SilverStarfall
Hi all!

I know there is a shitton of similar topics around, but please don't blame me for this one, as I have somewhat unique situation? Thanks in advance!

I purchased XIM4 in early 2018 and was successfully using it with my PS4 for many games FOR TWO YEARS (!).

Here is the breakdown of recent events:

1) I got deployed; brought my setup along and was happily playing "Prey" with it (no issues);

2) after that for a while I switched to games that didn't need mouse/kb setup; I also played a shared PS3 with my PS4 dualshock (their controllers were broken);

3) yesterday, I launched Metro Exodus DLC with XIM4 setup (I already finished the game with it before, even had the config loaded)

after 15 seconds to 1 minute, inputs stop responding and XIM4 turns solid white;

4) this brought me to this forum; I realized there was a new firmware update a month ago

- I factory reset my XIM4; install new firmware; delete all configs; delete the XIM manager app and re-install from scratch;

5) same issue: everything loads, keyboard inputs working, after 15-30 seconds (I tried BOTH idle and pressing buttons) XIM4 rapidly flashes yellow and then turns solid white; inputs stop responding, the app stops responding.

--------

Here is what I tried:

Connected XIM4 to PS4 with mouse and keyboard but NO controller; works like a charm. I sat on it for about 10 minutes, created and set up a new config from scratch - everything saved, no issues. I couldn't control PS4 of course, but it was reacting through iOS app. As soon as I connected controller - 30 seconds - crash.

Tried connecting controller while its on & off, tried connecting it after the XIM4 and together with it - no difference.

Factory-reset the controller - did not help. Fully charged it overnight from a wall, not PS4 - no change.

I checked the cable; it seems like the controller connects over BT only and doesn't recognize the cable. Because when I plug-in my Dualshock with micro-USB while its turned off, it doesn't come on; I have to press the PS button. Same, when you switch to cable instead of wireless, there's got to be an icon at the bottom of the PS4 quick-select menu that changes from "three battery bars" to like a "battery bar with a micro-usb icon in the left corner" - THIS DOESN't happen in my case. Can somebody confirm this?

Controller settings are set to "no vibration" and "over USB"; it is the SAME controller / cable / mouse / keyboard I was using for TWO YEARS; any ideas what the fu%# happened? Did I somehow fry the cable by using it with PS3? is this even possible?

Thank you guys.
« Last Edit: 05:36 PM - 03/26/20 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53210
    • View Profile
Re: XIM4 + Dualshock 4 : suddenly stopped working
« Reply #1 on: 05:36 PM - 03/26/20 »
Yes, you should see a USB icon over the controller in the PS4's quick menu. A white light is crash caused by an attached device, or corrupt configs. If it's only happening with the controller attached this points to the controller cable or the controller itself. I would start by testing other "mini usb" cables with the controller capable of data transfer and if this doesn't help then another controller next.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos


Admin