XIM Community

[ACTIVE] Xim 4 with Nav Controller issues  (Read 46 times)

Offline Dickkopf234

  • Member
  • *
  • Posts: 2
    • View Profile
[ACTIVE] Xim 4 with Nav Controller issues
« on: 07:39 AM - 03/26/20 »
Hi everybody,
I tried a lot, but my XIM4 won’t keep working. I read several topics here, but can't figure it out.
Before I start, here is my config:
Playstation 4 classic, Logitech G402 with a Playstation Navigation Controller.

I have the following issue:
While gaming, my controller suddenly stops working, neither mouse nor Navigation Controller working.
Either my Xim4 blinks in yellow for two or three times, then switches back to red, or sometimes completely shuts down.
If so, I have to plug it in again. Sometimes, even this won’t work, I have to put it back in to my PS4 several times because the cursor keeps going to the top left corner without any options to stop.

I tried two different Nav controller, two different mice, two different XIM4, nothing changes.
I read that I should try it with a USB hub 2.0, because it could be an issue with the power supply. Did that, nothing changes.
 Where am I supposed to put the Hub? Between PS and Xim4? Or between Xim4 and Navigation Controller?
I switched off the lights from my mouse,  fully charged both controllers and even tried another PS4 Controller. Nothing changes. 
One more issue besides, the Navigation controller does not always work wireless. I simply can not switch it on if it is not connected with the cable.
Thanks in advance, regards
Manuel
« Last Edit: 09:16 AM - 03/26/20 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53210
    • View Profile
Re: Xim 4 with Nav Controller issues
« Reply #1 on: 09:16 AM - 03/26/20 »
Welcome to the community and thank you for the detailed post. I think we may find the issue being related to your navs. Does this happen when using a standard non led keyboard?

The nav is prone to causing issues due to it's battery, cable, and eventual failure of the port. Nav batteries are very old at this point and your nav not being able to enter wireless mode shows this. It may help to charge the controller directly with the console, XIM and hub should be disconnected while charging. Using a powered hub in place of the APEX hub may help. Or add a power adapter to APEX's hub, if you would like to test with one APEX supports power adapters using the spec below and can be found on amazon or ebay. To prevent damage to your peripherals do not use a power adapter that doesn't match this spec and do not use a power adapter with an adjustable voltage switch.

5V 3A power adapter  ([3.5mm x 1.35mm], center-positive)
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos


Admin