XIM Community

[RESOLVED] XIM Apex not registering A key, double registering spacebar [PS4]  (Read 347 times)

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 53210
    • View Profile
Sure, if that's something you want to do we would appreciate knowing what exactly is or was causing this for you.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline hkp

  • Member
  • *
  • Posts: 12
    • View Profile
No problem!  I just tested with just the keyboard settings reverted.  Then with only boost mode turned off.  Then with only remote play turned back on.  No issues when only one setting is reverted.  I saved those logs but I think I'll hit a character limit if I post everything.


The problem only returned when I had the keyboard set back to key repeat delay to short and rate to fast in combination with boost mode being turned off.  When boost is ON and keyboard set to NORMAL, everything works fine.  When boost is OFF and keyboard is NORMAL, all is fine.  When boost is ON and keyboard set to SHORT/FAST, all is fine.  Boost set to OFF and keyboard set to SHORT/FAST reproduces the issue, below (repeating findings just to make clear, remove ambiguity).


Boost off and external keyboard set to short delay/fast rate



[03932] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  60,1000] U[50] [18] *^
[03933] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  53,  60,1000] U[50] [22] *^
[03934] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  69,1000] U[50] [14] *^
           HR[03] HT[04] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[151] | [151] | [  2] [C-K-MK]
      P4[130] GK[ 97] GM[ 75] GK[ 97] GK[111]
[03935] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56,  69,1000] U[50] [20] *^
[03936] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  53,  65,1000] U[50] [20] *^
[03937] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  69,1000] U[49] [15] *^
[03938] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  69,1000] U[50] [22] *^
[03939] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  64,1000] U[49] [15] *^
           HR[03] HT[04] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[156] | [156] | [  3] [C-K-MK]
      P4[129] GK[ 97] GM[ 75] GK[ 97] GK[117]
[03940] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58,  69,1000] U[50] [18] *^
[03941] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56, 220,1000] U[50] [22] *^
[03942] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  69,1000] U[50] [14] *^
[03943] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  59,  69,1000] U[50] [19] *^
[03944] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  67,1000] U[50] [21] *^
           HR[03] HT[04] DV[00] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[160] | [160] | [  4] [C-K-MK]
      P4[132] GK[101] GM[ 75] GK[ 97] GK[116]
[03945] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56,  70,1000] U[50] [14] *^
[03946] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57, 136,1000] U[50] [21] *^
[03947] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  68,1000] U[49] [16] *^
[03948] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58, 213,1000] U[50] [18] *^
[03949] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  69,1000] U[50] [22] *^
           HR[03] HT[04] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[296] | [296] | [  4] [C-K-MK]
      P4[277] GK[ 97] GM[ 75] GK[ 97] GK[116]
[03950] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  51,  60,1000] U[50] [14] *^
[03951] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57, 307,1000] U[50] [18] *^
[03952] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  69,1000] U[50] [22] *^
[03953] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  70,1000] U[50] [13] *^
[03954] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  71,1000] U[50] [21] *^
           HR[03] HT[03] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[314] | [314] | [  4] [C-K-MK]
      P4[295] GK[ 97] GM[ 76] GK[102] GK[116]
[03955] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  52,  65,1000] U[50] [17] *^
[03956] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  65,1000] U[50] [17] *^
[03957] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56,  68,1000] U[50] [22] *^
[03958] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  69,1000] U[50] [15] *^
[03959] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  69,1000] U[50] [18] *^
           HR[03] HT[03] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[308] | [308] | [  4] [C-K-MK]
      P4[290] GK[ 94] GM[ 76] GK[ 94] GK[112]
[03960] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55, 178,1000] U[50] [23] *^
[03961] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  55,  68,1000] U[50] [12] *^
[03962] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58,  69,1000] U[50] [21] *^
[03963] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  65,1000] U[49] [18] *^
[03964] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58,  69,1000] U[50] [17] *^
           HR[03] HT[04] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[321] | [321] | [  3] [C-K-MK]
      P4[303] GK[ 97] GM[ 75] GK[ 97] GK[107]
[03965] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56, 137,1000] U[50] [22] *^
[03966] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  54,  68,1000] U[49] [15] *^
[03967] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58,  69,1000] U[50] [18] *^
[03968] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  56,  69,1000] U[50] [23] *^
[03969] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  57,  71,1000] U[50] [13] *^
           HR[03] HT[04] DV[01] TR[08] BT[00] TW[00] UI[00] EN[00]
    T0[287] | [287] | [  4] [C-K-MK]
      P4[268] GK[ 97] GM[ 76] GK[ 97] GK[116]
[03970] Q[0] E[0] M[0] | S[0] C[0] T[0] I[0] R[  58,  69,1000] U[50] [20] *^

Offline hkp

  • Member
  • *
  • Posts: 12
    • View Profile
So, when I experimented with turning settings off to repeat the issue, the issue didn't go away after I restored what I thought was working.


It's gone from no issues for a whole day, a few unregistered A keys and double registered spacebars the next day, to 1:1 failures again. I'll try dusting off my XB1 and seeing if the issue occurs on that platform.  If not, I guess my only recourse will be a factory restore of my PS4, huh?


If the problem persists on the XB1, then I'd have to assume it's either the XIM or a lack of a powered USB hub?

Offline hkp

  • Member
  • *
  • Posts: 12
    • View Profile
Sure, if that's something you want to do we would appreciate knowing what exactly is or was causing this for you.


So the issue is still happening on a completely different PS4 that I just fresh installed.  Could this all be because I need a powered hub?  Could I somehow have gone through 15+ noncompliant USB cables?


Is there a specific brand of USB I should be trying that you can link on Amazon or Newegg? 

Offline hkp

  • Member
  • *
  • Posts: 12
    • View Profile
Ok, ok.  I'm going to be an adult, here.  I think I fixed the issue.


I had a sudden memory that, while my Orbweaver's A key also had issues, the spacebar issue on my current keyboard actually was happening on the Orbweaver's alt key.  This got me thinking it may not be a software issue.  Took a flat bracket, popped off the key, and sure enough there was some debris.  It's now working as normal.


Sometimes we (i.e. me) miss the easiest solutions.  ::)


Admin