XIM Community

Logitech G502 DPI side buttons not recognized via XIM APEX software  (Read 1311 times)

Offline Visuals

  • Member
  • *
  • Posts: 28
    • View Profile
Can anyone tell this silly fool (myself) where exactly in the new software manager for the Logitech G502 lightspeed I can assign the DPI buttons so that the "presses" can be recognized in the XIMApex software... I've gone in and assigned my But away many times to come out of the software and it still not work....

I may be doing something wrong, but not sure what

Thank you all

Cheers!

Offline AgentSmith

  • MVP
  • *
  • Posts: 579
    • View Profile
Use the LGS or G-Hub ( mouse software ) to assign the side button to a key.

Make sure it is being saved to the MOUSE MEMORY like I showed you in the rapid fire tutorial I did for you.

An example would be Assign one of the buttons to be P    so when you press it the Xim will see it as a P.

Of course you can use whatever key you like I just suggested P as its out of the way and unlikely to be used otherwise.


Offline year0

  • MVP
  • *
  • Posts: 631
    • View Profile
Use the Logitech Gaming Software, the G—Hub SUUUX
Has anyone really been far even as decided to use even go want to do look more like?

Offline OhBlivEeUn

  • Member
  • *
  • Posts: 113
    • View Profile
Use the Logitech Gaming Software, the G—Hub SUUUX

I didnt even know the alternative... lately I can't even open the app my DPI is a mystery to me these days lol

Offline year0

  • MVP
  • *
  • Posts: 631
    • View Profile
Might need to update your dot net..
Just to be clear :- you’re using LGS or Ghub? It sounds like you’re maybe not running the mouse in onboard memory mode, and I recall g-hub being particularly annoying with regard to this specific settin
Has anyone really been far even as decided to use even go want to do look more like?

Offline psychonaut

  • Member
  • *
  • Posts: 9
    • View Profile
Might need to update your dot net..
Just to be clear :- you’re using LGS or Ghub? It sounds like you’re maybe not running the mouse in onboard memory mode, and I recall g-hub being particularly annoying with regard to this specific settin

I'm almost 100% sure LGS doesn't work with the lightspeed G502. Have to use Hub software. And yes it's nitpicky, took me a few tries to get it down but got all buttons working. I suggest setting up your mouse, plug it into xim, if it doesn't work go back to pc and try again. Takes a couple tries but you'll get it. ^_^

Offline Tetsurobash

  • Member
  • *
  • Posts: 396
    • View Profile
  • PSN ID: Apollo-ZuEs-LeTo
You should also be able to change dpi up down buttons in the mouse software... for example you could bind them to scroll right/left (normally assigned to mouse wheel) then be able to use them in the xim manager. Some of the options for reassigning buttons won’t translate though... like assigning play, pause etc. I’m pretty sure xim won’t accept it.

Offline year0

  • MVP
  • *
  • Posts: 631
    • View Profile
Might need to update your dot net..
Just to be clear :- you’re using LGS or Ghub? It sounds like you’re maybe not running the mouse in onboard memory mode, and I recall g-hub being particularly annoying with regard to this specific settin

I'm almost 100% sure LGS doesn't work with the lightspeed G502. Have to use Hub software. And yes it's nitpicky, took me a few tries to get it down but got all buttons working. I suggest setting up your mouse, plug it into xim, if it doesn't work go back to pc and try again. Takes a couple tries but you'll get it. ^_^

Can confirm it works with my g502 hero (wired) but I haven’t tried with the
Lightspeed (that’s the wireless correct?)

I mapped all my buttons to a keystroke
Has anyone really been far even as decided to use even go want to do look more like?


Admin