XIM Community

[ACTIVE] Xim Apex suddenly not working anymore  (Read 767 times)

Offline Sphynxerino

  • Member
  • *
  • Posts: 27
    • View Profile
[ACTIVE] Xim Apex suddenly not working anymore
« on: 06:26 AM - 11/10/19 »
Hi,

I got my xim apex last december/january and had no problems with it. I didn't use it very much, maybe 2-3 month in total. I used it always with a corsair RGB strafe silent and a Logitech G900 with a ps4 controller. I never changed something.

After playing yesterday, I shut down everything as usual. This morning, the xim would connect to the xim manager, but didn't show the ps4 controller, mouse or keyboard. I unplugged and replugged the xim about 20 times with no changes. If I put the the usb hub (without xim) into the pc, everything lights up and works. The xim doesn't work on pc or ps4. Both the same symptoms. The xim shows the normal start blinking with going to my first setting. The controller is fully charged (directly to the ps4).

I thought maybe reinstall firmware? But the pc won't recognise the xim either. Pressing the butten, pluggin in the xim, waiting...nothing happens. light stays blue with nothing happening. I tried two different usb hubs - no luck either. I ran out of ideas.

Is there something I could try?

Edit: I was able to do a factory reset with the same result. wont recognise anything :-(
« Last Edit: 05:02 PM - 11/10/19 by OBsIV »

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 30070
    • View Profile
Re: Xim Apex suddenly not working anymore
« Reply #1 on: 12:09 PM - 11/10/19 »
Hey,

what light sequence does the xim show after the initialization lights?
Also does the XIM work if you only connect the controller and the mouse to it?
And does the XIM Manager still show you the button presses of your devices at the bottom?
PS4 & X1 | C: MS | XIM4 | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Zowie EC1-A | D: 3200 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

My Fortnite Creator Code: beamimpact
Check out my Youtube Channel: XIMGameplay

Offline Sphynxerino

  • Member
  • *
  • Posts: 27
    • View Profile
Re: Xim Apex suddenly not working anymore
« Reply #2 on: 12:26 PM - 11/10/19 »
It looks like red, yellow, green, blue, then the color of the config.

No, the xim does not recognise the controller, mouse or keyboard. Even if I plug in the device directly into the xim.
No, the xim manager does not show the button press. It sees the xim  and let me load my configs, but the grey area where usually the devices are show, is empty. Also my hotkeys to load my configs dont work - cause it cant see my KB.

No matter if I use the original Xim hub or an different one. I even tried the usb hub from my brother with the same result.

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 36786
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Xim Apex suddenly not working anymore
« Reply #3 on: 05:02 PM - 11/10/19 »
So when you plug any of your devices directly into your XIM APEX (no hub) none of your devices don't show up in Manager at all?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline Sphynxerino

  • Member
  • *
  • Posts: 27
    • View Profile
Re: Xim Apex suddenly not working anymore
« Reply #4 on: 09:28 PM - 11/10/19 »
So when you plug any of your devices directly into your XIM APEX (no hub) none of your devices don't show up in Manager at all?

That is correct. No device at all.
This tells me, that the USB Hub is most likely working, since everything works when I plug it into a PC (without the xim, just the usb hub with devices). So there is no communication after the xim, right? Because I can reinstall the firmware, but nothing after the xim works.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 52979
    • View Profile
Re: [ACTIVE] Xim Apex suddenly not working anymore
« Reply #5 on: 10:39 AM - 11/11/19 »
Earlier you mentioned XIM not responding to your PC Manager I think? Were you using wired config mode? This is needed to use Manager on PC. To use wired config mode attach XIM to the PC without holding a button. When the startup lights begin to flash immediately press and release the XIM button, the light sequence will be interrupted and you should then be able to open and use Manager in wired mode.

It's normal for your mouse and keyboard to not work with your console after a factory reset until a config has been added. I'm not sure I understood this correctly but I just wanted to clear it up just in case.

Yes, if the hub is working on a PC it's not the hub. There may be an issue with APEX if it's not recognizing peripherals at all with direct connection. Your peripherals shouldn't be functioning but they should power on and a device icon for that peripheral should appear the top of Manager. To confirm it's not powering or showing an icon for anything with direct connection to APEX? If so could you try using APEX in other ports on the console?
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Sphynxerino

  • Member
  • *
  • Posts: 27
    • View Profile
Re: [ACTIVE] Xim Apex suddenly not working anymore
« Reply #6 on: 12:24 PM - 11/11/19 »
Yes I thought the PC didn't recognise it, but it did. It was my fault. Usually I got a message from windows as soon as I put it in, but in this case there was no sign of the xim shown, so I assumed it didn't work. I then opened up the firmware .exe and it did see the xim. So this is on me.

I did not use the wired mode. I held the xim button, plug it into the PC, light is blue, i let the button go. Just the "normal" way of updating firmware. This way I was able to backup my configs and factory reset the xim. I even tried to restore my configs and it worked.

I know the mouse and keyboard would not work, so I loaded 2 different configs. A new COD MW and a Battlefield V. Same resault - no Icons of the devices in the grey box. No power to the devices (no lights, nothing).

I tried the xim now on a Playstation 4, a PC and a Xbox One with the same resault.
The xim of my brother worked with my ps4, the PC and  the Xbox WITH my original xim usb hub, so I guess it's 100% not the hub. :-/

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 52979
    • View Profile
Re: [ACTIVE] Xim Apex suddenly not working anymore
« Reply #7 on: 05:37 PM - 11/11/19 »
Does it look like there could be a bent pin either in the connector or port end of APEX? This could just be a bent pin but this would be visible. Otherwise unfortunately it looks like your APEX will need to be looked at for repair if it's not powering and recognizing devices with direct connection. To request a repair please use the appropriate link below.

If purchased from xim.tech/shop in the last year please open an RMA using your store account:
http://store.xim.tech/myaccount.asp

If purchased from another location or the purchase date exceeds one year please open a ticket in our store:
https://store.xim.tech/crm.asp?action=add
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Sphynxerino

  • Member
  • *
  • Posts: 27
    • View Profile
Re: [ACTIVE] Xim Apex suddenly not working anymore
« Reply #8 on: 03:36 AM - 11/12/19 »
The Pin/opening looks normal and identical when I compare the two xims.

Thank you very much for the help.