XIM Community

[RESOLVED] XIM Apex stopped working  (Read 190 times)

Offline jathoma9

  • Member
  • *
  • Posts: 3
    • View Profile
[RESOLVED] XIM Apex stopped working
« on: 12:01 PM - 10/21/19 »
10/20/2019 6:42:40 PM   Product stopped working without me doing anything to it. I use it with the hub and plug in my mouse in port 1, keyboard in port 2, and ps4 pro controller in port 3. I also plug in another power source to it. I also have "connect via usb" being on in the settings. Finally, I plug the hub into the xim apex dongle, which I plug into the player 1 usb into the ps4. This setup has worked wonders for me and I beat the entirety of uncharted 4 with this setup. I also have the app, and usually what happens is:

1. as far as the controller goes, the dim bar of the controller has always shown a solid yellow color light when it was working.
2. as far as the app goes, my mouse, keyboard, and controller were all shown in that top bar when it was working.

Now what happens is:
1. the controller, despite being fully charged, has a yellow light, but it is sort of flashing instead of being solid. Flashing may not be the right word - it sort of pulses, slowing fading away then fading back yellow, then fading again. hitting the playstation button makes it read as bluetooth despite the setting, "connect via usb" being on in the settings.
2. my mouse and keyboard show up on the app, but the controller does not.

I have tried the following:
1. replacing the hub with a third party hub (the ugreen)
2. replacing usb micro cables i hook the controller to
3. replacing the ps4 controller
4. resetting the controller with the port on the back.
5. reset my ps4 by holding the button for 15 seconds to power it down, then unplugging it for 60 seconds
6. getting the latest firmware for the product

None of it have worked, and I am at a loss. I can't help but feel it's the xim apex dongle at fault here, and that there is nothing else that can be done troubleshooting-wise. I wish to exchange it for another one. When I sent this as a ticket, someone responded and directed me here. Is there anything else I could be missing, and if I am not missing something, how can I get my xim apex replaced?
« Last Edit: 06:02 PM - 10/24/19 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 52279
    • View Profile
Re: XIM Apex stopped working
« Reply #1 on: 04:33 PM - 10/21/19 »
Welcome to the community. I don't have another suggestion now but if I know two pieces of information we may know if it's APEX related. We should verify the controller can authenticate with APEX using direct connection. This will tell us whether the hub is at fault or an attached peripheral is conflicting. Please run this test.

Disconnect APEX
Disconnect hub
Connect controller directly to APEX
Connect APEX to console
Watch APEX startup lights

Do you see 4x green lights during APEX's startup light sequence?

The second is connecting the controller to a PC and either testing it in a PC game or testing it in the windows controller preview.
« Last Edit: 04:39 PM - 10/21/19 by mist4fun »
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline jathoma9

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] XIM Apex stopped working
« Reply #2 on: 06:40 AM - 10/23/19 »
I will try this tonight

Offline jathoma9

  • Member
  • *
  • Posts: 3
    • View Profile
Re: [ACTIVE] XIM Apex stopped working
« Reply #3 on: 04:40 PM - 10/24/19 »
I did the test and it worked, then i tried the hub again and...it worked? It like fixed itself or there was somnething else going on. either way, thanks for answering!

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 52279
    • View Profile
Re: [ACTIVE] XIM Apex stopped working
« Reply #4 on: 06:02 PM - 10/24/19 »
Maybe it was a poor connection? I'm glad it's working again.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos