XIM Community

[ACTIVE] XIM Apex | Controller won't register with the XIM anymore  (Read 190 times)

Offline austincoburn

  • Member
  • *
  • Posts: 1
    • View Profile
  • Gamertag: Voitro
So I've had my XIM Apex for a couple months but all of a sudden it stopped working (the controller connection). I rebooted my xbox and unplugged and replugged everything but the issue is, the XIM is not connecting with my controller. I tried different controllers, different cords but kept on getting the same result.  When I plug the cord from the XIM into my controller, the controller vibrates but will not turn on.

On my XIM app, only the mouse and keyboard work.

« Last Edit: 04:32 PM - 07/31/19 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58824
    • View Profile
Re: XIM Apex | Controller won't register with the XIM anymore
« Reply #1 on: 04:32 PM - 07/31/19 »
Welcome to the community. Does APEX recognize the controller if it's using direct connection without the hub?

Also, we should verify the controller can be used in wired mode with the console next. This is required for your mouse and keyboard to function with XIM. Please run this test.

Disconnect XIM
Remove controller battery ( important )
Connect controller directly to console

Does the controller light turn on automatically without pressing buttons?
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos