XIM Community

[RESOLVED] XIM4 power failure  (Read 152 times)

Offline Hogslayer

  • Member
  • *
  • Posts: 5
    • View Profile
[RESOLVED] XIM4 power failure
« on: 05:11 AM - 07/19/19 »
Hi

Setup:

Rocca sova mk keyboard
Logitech g402 mouse
Ps4 pro and Xbox one x (same problem on both)
XIM4

My XIM4 worked perfectly with this setup for about one year and 6 months. Then all of a sudden I started getting the flashing yellow and red lights while playing games. Never while in menus etc, only when actually running around in games.

I turned off lights on the mouse and keyboard. I updatet the XIM4 to the newest software. This did not immediately fix the problem, however the next day it suddenly worked allright again.

I had no more problems for about two weeks. Now I again Get the flashing yellow and red lights while playing. It happens within a couple of minutes after starting a game (apex legends or pubg). Never in Xbox/ps4 menus or ingame menus.

Help
« Last Edit: 09:12 AM - 07/23/19 by mist4fun »

Offline Hogslayer

  • Member
  • *
  • Posts: 5
    • View Profile
Re: XIM4 power failure
« Reply #1 on: 05:21 AM - 07/19/19 »
The controller is fully charged and vibration is turned off

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54001
    • View Profile
Re: XIM4 power failure
« Reply #2 on: 09:33 AM - 07/19/19 »
This isn't uncommon for people using LED peripherals, extended cables, or lapboards like the Sova. The power fault happens when your devices aren't receiving enough power from the console. Disabling lighting doesn't always reduce power draw. If you have a non led keyboard try using it instead of the Sova. If there are no power faults then you should be able to solve this using a powered hub between XIM4 and your mouse and keyboard.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Hogslayer

  • Member
  • *
  • Posts: 5
    • View Profile
Re: [ACTIVE] XIM4 power failure
« Reply #3 on: 03:27 AM - 07/23/19 »
I switched out my mouse with the new glorious O (which by the way rocks LED-lights). Everything works perfect now.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54001
    • View Profile
Re: [ACTIVE] XIM4 power failure
« Reply #4 on: 09:12 AM - 07/23/19 »
I'm glad you have it working and thanks for updating your thread. I wouldn't have expected that, I wonder if the G402 uses more power than the O.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos