XIM Community

[ACTIVE] Potential problems with USB hub?  (Read 182 times)

Offline AvAtA

  • Member
  • *
  • Posts: 2
    • View Profile
[ACTIVE] Potential problems with USB hub?
« on: 04:22 PM - 07/12/19 »
Hello, I just got an Xim Apex direct from the Xim site and have been having some issues with it already.

On Wednesday I tried plugging it into the PS4 and wasn't getting any connections on my phone manager. The keyboard and mouse I had plugged in were also not powered (they each have a little glowy logo on them that wasn't lit).
So I ordered a power cable for the hub and a new power/data USB for the controller, and now the kb/m will light up, but I'm still not getting them to pop up on my manager.

If I plug the controller straight into the Xim Apex, the controller functions and the manager will display my inputs, so I don't think the Apex itself is faulty. However, if I plug the USB hub into my computer and plug the keyboard in, it'll only connect if the cable is in certain orientations (like, nothing will work, then I'll move the cable slightly and it'll start working, then if it moves again it'll disconnect again).

I'm wondering now, is it possible to use a third-party powered USB hub instead of the one sent by Xim?
Any help or insight would be greatly appreciated.
« Last Edit: 04:36 PM - 07/12/19 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58844
    • View Profile
Re: Potential problems with USB hub?
« Reply #1 on: 04:36 PM - 07/12/19 »
Welcome to the community and thanks for sharing your troubleshooting results. It does sound like there may be an issue with this hub. To request a replacement please use the appropriate link below. I'm sorry for the inconvenience. If you have a spare hub it should work with APEX as well in the meantime.

If purchased from xim.tech/shop in the last year please open an RMA using your store account:
http://store.xim.tech/myaccount.asp

If purchased from another location or the purchase date exceeds one year please open a ticket in our store:
https://store.xim.tech/crm.asp?action=add
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline AvAtA

  • Member
  • *
  • Posts: 2
    • View Profile
Re: [ACTIVE] Potential problems with USB hub?
« Reply #2 on: 05:09 PM - 07/12/19 »
Thanks for the fast reply!
It's definitely the USB hub. I tied it into a loop that worked with a small twist tie and was able to get it working for a little bit, but then the mouse cord tugged on it slightly and it disconnected again.

I'd rather not go through the hassle of ordering a replacement, if I were to buy a third-party hub are there any specifications I should look out for? I know I should stick to USB 2.0, right?

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 44156
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: [ACTIVE] Potential problems with USB hub?
« Reply #3 on: 09:17 PM - 07/12/19 »
Really sorry to hear you are having problems with the hub. Yes, there is nothing special about it -- it's just a standard USB 2.0 hub and for best compatibility you should stick with USB 2.0. But as mist says, we'd be happy to take care of it.
Get the most out of your XIM NEXUS, read the XIM NEXUS Support FAQ.


Admin