XIM Community

Logitech g903 mouse side buttons don't work  (Read 716 times)

Offline d0x360

  • Member
  • *
  • Posts: 5
    • View Profile
Logitech g903 mouse side buttons don't work
« on: 01:55 PM - 02/14/19 »
Is there anyway to get the 2 side buttons to work on the Xim Apex or even the Xim4 as I own both?  If I can't make it work is it possible to get this mouse added to the supported list?  I think the issue might be that it's technically wireless so the receiver plugs into the Xim but so was my older mouse (as detailed below) and the side buttons worked on that.

My older mouse, a Logitech g602 has 6 buttons down the left hand side and I believe (it's been a while) that at least 2 if not 4 of them worked fine with the xim4.

I upgraded about a year ago but just started using my xim4 again about a month ago and I got the Apex on Monday.  Neither see the side buttons on the 903 which...stinks.

I kinda need at least 1 extra button on the mouse beyond left, right and middle click.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54017
    • View Profile
Re: Logitech g903 mouse side buttons don't work
« Reply #1 on: 02:06 PM - 02/14/19 »
This can be done by assigning these extra buttons as keyboard keys in LGS so that XIM can identify them. Connect the mouse to a PC and open LGS. Click the home icon near the bottom. Select onboard memory near the top.


Click the mouse memory icon near the bottom to switch to this screen.


Here you can reassign buttons on the mouse to unused keyboard keys. Choose keys that aren't normally used in your config like: o p k l n m.

I recommend removing the extra DPI levels and profiles on this screen if you don't intend to use them to prevent accidental switching during play.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline d0x360

  • Member
  • *
  • Posts: 5
    • View Profile
Re: Logitech g903 mouse side buttons don't work
« Reply #2 on: 01:45 PM - 02/15/19 »
Ahh ty so much.  I had them set to back and forward for the browser.  I probably should have thought of that.

Much appreciated, take care.