XIM Community

[RESOLVED] Doesn't work  (Read 105 times)

Offline NauticalNewt27

  • Member
  • *
  • Posts: 2
    • View Profile
  • Gamertag: NauticalNewt27
[RESOLVED] Doesn't work
« on: 08:12 PM - 01/10/19 »
I got my apex a few days ago I plug everything worked just fine. Went to use it again and nothing turned on. My friend has one and he was trying to help me fix it tell me different things people say help off the forums but nothing worked. I went over his house to see if I needed to update the adapter (cause I don't have a computer) and it still didnt work we then tested all his stuff on my xbox and it worked fine and kept trying different things between both our adapters and cords. Come to find out the splitter that was given to me with the apex doesn't work. The light comes on saying it does but not enough power goes through or something because it says I'm taking up to much power in the app but my friend has the exact same configurations and his works fine. Don't know what to do I can't spend any more money on this stuff.
« Last Edit: 10:03 AM - 01/11/19 by mist4fun »

Offline antithesis

  • MVP
  • *
  • Posts: 8039
    • View Profile
    • Mod Squad
Re: Doesn't work
« Reply #1 on: 04:56 AM - 01/11/19 »
If you're getting power failure indications through the XIM (red & yellow lights or lightning bolt icons in XIM Manager), that's due to the console not being able to supply enough power to your mouse and keyboard.

This is typically caused by keyboards with RGB lighting, or wireless mice wired up for recharging, or controllers that aren't fully charged.

The solution is frequently very simple - buy a power adapter to connect to the Apex USB hub to add power to your setup.

Before doing that, please post your mouse and keyboard for troubleshooting as there may be a different cause.

The first thing you can try while waiting for a tech support response is to fully recharge your controller by connecting it direct to the console. Alternately, on XB1 you can remove the battery when the controller is connected to XIM.

Official Australian distributor for XIM Apex, Titan One & Titan Two at Mod Squad
XIM Apex demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline NauticalNewt27

  • Member
  • *
  • Posts: 2
    • View Profile
  • Gamertag: NauticalNewt27
Re: Doesn't work
« Reply #2 on: 08:10 AM - 01/11/19 »
I don't think it's my xbox. My friend and I have the exact same stuff keyboard, mouse, settings everything we tried using his adapter cords and stuff on my xbox and it worked. I gave him my stuff to use but it did not work on his. We switched everything out over and over everything that he had worked but when I gave him just my splitter to use it gave him the power failure it gave me. While his splitter worked for my setup.

Offline antithesis

  • MVP
  • *
  • Posts: 8039
    • View Profile
    • Mod Squad
Re: Doesn't work
« Reply #3 on: 08:23 AM - 01/11/19 »
In which case, it does sound like a faulty USB hub. Don't worry, you're covered by warranty.

I'm sure mist will see this and offer a solution.

It's frustrating when something doesn't work off the bat, but the XIM will be worth it in the end :)

Official Australian distributor for XIM Apex, Titan One & Titan Two at Mod Squad
XIM Apex demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51322
    • View Profile
Re: Doesn't work
« Reply #4 on: 10:03 AM - 01/11/19 »
Welcome to the community and thank you for sharing what you've learned from troubleshooting. I'm sorry to hear about the hub failure, let's work toward getting you a new one. To request a replacement hub please open a ticket in the store using the link below. APEX should work with other USB 2.0 hubs if you happen to have one.

https://store.xim.tech/crm.asp?action=add
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos