XIM Community

[RESOLVED] Keyboard and Mouse loose connection  (Read 178 times)

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
[RESOLVED] Keyboard and Mouse loose connection
« on: 11:14 AM - 12/06/18 »
Hi Guys

I purchased the Xim Apex on nov 1st for my PS4.

Before installing, I read all the tutorials and watched videos.
After everything was setup, it performed flawlessly, until today.

My K&M disconnect after about 2-5 minutes of switching on.
It's like they loose power as all LED's switch off.

I'm using a Razor Lycosa and Naga.

I have done a factory reset and am now running the latest firmware, but the problem still persists.

PS4 controller is fully charged, but the problem remains.

Changed to a different port on the PS4 console, but the problem remains.

Settings on console have been performed as suggested, controller connected via USB cable.

Xim does not change colour when the K&M disconnect.

Shall I return it and ask for a new one?

Thanks in advance.

« Last Edit: 10:19 AM - 12/11/18 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: Keyboard and Mouse loose connection
« Reply #1 on: 11:53 AM - 12/06/18 »
Welcome to the community. Are you using a third party usb hub, usb switch, or extended usb cable?

Issues like this are usually setup related. I recommend connecting the controller directly to the console to charge for about an hour. XIM and hub should be disconnected while charging. The issues is likely related to your high power peripherals. If power is responsible for this then adding a power adapter should help. To troubleshoot, if you have non-led peripherals please try using these.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #2 on: 12:16 PM - 12/06/18 »
Thanks for the reply.

The controller was already on charge and fully charged prior to setting up and starting to play.

I did suspect that it could be a power draining issue and as I do have the option to turn off the LED's on the KB,
I did test this out, but the K&M still switch off.

I have just tried a different K&M, an El Cheepo setup, but still, the switched off.

When you say add a power adaptor, do you mean getting a USB hub that is powered with an AC Adaptor?


Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #3 on: 12:21 PM - 12/06/18 »
Are you using a third party usb hub, usb switch, or extended usb cable?

Disabling LEDs usually doesn't help with this, the devices are still drawing more power than non-led devices. This is fine when each device has it's own PC port but when used on a hub or in this case with XIM the power draw demand can cause stability issues. APEX has a small port for a power adapter on the back of it's hub. If you would like to try adding additional power APEX supports power adapters using the spec below and can be found on amazon or ebay.

5V 3A power adapter  ([3.5mm x 1.35mm], center-positive)

If the issue is occurring with two non-led peripherals then we should look at testing new cables or another controller next.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #4 on: 12:22 PM - 12/06/18 »
Sorry, I also want to mention that in the beginning, it was working fine with the Razer K&M and I could play for hours with no issues. this is what's mind boggling.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #5 on: 12:23 PM - 12/06/18 »
That's not uncommon with high power setups actually.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #6 on: 12:30 PM - 12/06/18 »
Not using any third party devices or hubs. Everything is standard as it came in the box.

I will have to test the AC Adapter tomorrow as I have some at work that i can test with.

Will let you guys know tomorrow how it goes.

Thanks again for all the help. Excellent support service.


Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #7 on: 12:31 PM - 12/06/18 »
Of course. Please let us know how it goes.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #8 on: 12:41 AM - 12/10/18 »
Morning Guys.

Sorry I haven't replied yet. I still need to find an AC Adapter, so will reply as soon as I find one and tested it out.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #9 on: 09:39 AM - 12/10/18 »
Not a problem, please bump this thread once you've had more time to troubleshoot.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #10 on: 10:11 AM - 12/11/18 »
Hi Guys.

I am pleased to report that the AC Adapter has solved the issue.
Now that the hub is powered, the K&M do mot loose connection.

Thank you all for the help. Much appreciated.

Sorry, 'Bump'?

Thanks again.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 51196
    • View Profile
Re: [ACTIVE] Keyboard and Mouse loose connection
« Reply #11 on: 10:16 AM - 12/11/18 »
That's good to hear. I'm glad the power adapter solved the stability issue.

Maybe I should have used update there? :) Bump is a term used when posting in a thread, after posting the thread is moved to the top of the list for better visibility.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline RuiValentim

  • Member
  • *
  • Posts: 7
    • View Profile
Re: [RESOLVED] Keyboard and Mouse loose connection
« Reply #12 on: 01:23 AM - 12/12/18 »
Morning.

Thanks for the educational tip....lol, and thanks again for the great support.

Have a goos one.