XIM Community

FEEDBACK: Aiming behavior differences (upgrade vs Config re-create)  (Read 1522 times)

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 36049
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Hey everyone, I've seen a few mentions from some stating that their aim was really off (like unplayable) after upgrading to the latest Beta, but, after they re-created their Configs the problem went away.

If you experienced this, please let me know here -- especially if you have a backup copy of the Configs that you had to re-create. This is certainly something we need to track down.

Thanks for your help!
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline YogurtcuBayram

  • Member
  • *
  • Posts: 76
    • View Profile
I tried 0 and off. sorry but still not like retail or 0603.
Ps4 Pro
Logitech G502
Corsair K68
Steelseries qck+

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 36049
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
I tried 0 and off. sorry but still not like retail or 0603.

Did you upgrade and/or re-create your Configs? The reason I ask this is because 0613 is identical to 0603 except for the ability to turn off SAB completely. So, there must be another bug going on.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline YogurtcuBayram

  • Member
  • *
  • Posts: 76
    • View Profile
Yes i made factory reset and recreated configs.
Ps4 Pro
Logitech G502
Corsair K68
Steelseries qck+

Offline Xdrqgol

  • Member
  • *
  • Posts: 131
    • View Profile
I have had issues like mentioned in the other thread.

Once I have recreated the config , I was blown away by the fact that I had to adjust many other settings which previously I didn't due to not seeing any need...

configs where sent to you already, check your PM
8) Power Overwhelming 8)

Offline LeMiiRx

  • Member
  • *
  • Posts: 24
    • View Profile
  • PSN ID: LeMiiRx
So actually iam using 0603 and i mostly play r6 sometimes iam having problem with my aim i upgraded it and everything was worse but when iam re-config everything will be better than before

Offline JamesCaywood

  • Member
  • *
  • Posts: 183
    • View Profile
  • Gamertag: ScaryFawn631545
Hmmm me and my friend is noticing this ads on fortnite like two magnets facing away from each other  kinda far / medium range it's hard to keep it on them as right when I got it on them it hovers over them really fast. Using persifn config with the newest beta
« Last Edit: 07:48 PM - 06/27/19 by JamesCaywood »

Offline Die_Hard

  • Member
  • *
  • Posts: 164
    • View Profile
  • PSN ID: aalsarram
Apex legends still unplayable while ads I restored the xim to factory settings and reupdate and still specially while ads aim goes unpredictable 💔

Offline BlueAid

  • Member
  • *
  • Posts: 344
    • View Profile
Apex legends still unplayable while ads I restored the xim to factory settings and reupdate and still specially while ads aim goes unpredictable 💔

With what firmware and manager?
CM MasterKeys Pro M White | Logitech G203 | Steelseries QcK Heavy

PS4 Pro | Xbox One S

XIM APEX | XIM 4 | XIM Edge

Offline WarCat

  • Member
  • *
  • Posts: 104
    • View Profile
I've updated to 0613 and it is hard to say  whether or not there is a distinct difference between the firmware. Since the update a few weeks ago to Apex Legends, everything has been inconsistent for me. The server went from 60 hz to 20hz essentially because packet splitting was implemented there. On top of that, default server assignments were broken, and now you have people from random parts of the country / world being assigned to what would be your best server (via ping) or you yourself may be placed in another server. Its caused all kinds of frustration for me, so it is very hard to say whether or not I feel a difference caused by the XIM or not. No match has felt the same for me to use as a baseline.

I was using advanced look controls with Apex Legends prior to update 0601, but I switched back to default as they felt horrible after the update (this could have been the lag that followed the update though, incorrect server assignments, netcode issues, etc) but I had seen others say the advanced look controls felt horrible after the Apex Legends update as well, so I switched back to the ST supported default settings.

After seeing this thread, I decided to factory reset and reinstall 0613 firmware. Rebuilt my current config from scratch as people have mentioned. I am using 7,7 in game on common sync and 500 hz polling, as suggested by d1sable. 150 SAB on ADS only, and some secondary key assignments for things like ping, change weapon, crouch, and game menu. I am not using any kind of aux configs and I have not used XIM link for a little while now.

I did go into training mode and everything seemed to work fine though, I have practiced quite a bit there doing flick shots, tracking, target switching, etc. No noticeable unpredictable aim behavior. I am wondering if it has something to do with aim assist in the game? I believe it is also present in the training mode, but maybe not as strong. Could the terrible performance with lag and dropped frame rate in Apex heavily influence your aim, similar to how smoothing could increase AA? This has been a problem since the start of this game, in game has not felt nowhere near as good as the training range, I don't know if it is just network and hardware performance or if there is something else going on in the background there, perhaps it was made worse by the Apex Legends update and/or the firmware update some how.

For those experiencing these issues, have you tried it in training mode with the same issues? Can you post a video so I know better what to look for? Is there any other variables that are in your setup like XIM Link or Titan 2, that may not be in others? This issue is just too inconsistent for anyone to drill down without more information.

In case my thoughts got a little diluted there through that novel, my main point is:
- I've not noticed a major difference between when I first updated my XIM from 0603 to 0613 firmware
- Could lag / framerate be negatively affecting our aim?
- Is it concrete that this issue is ONLY present in 0613 firmware, or what is the last known "working" firmware?
- Is the issue present in training modes?
- Is the issue constant?
- Define unpredictable aiming behavior so it is better understood, do you aim left and it goes right? etc.
- Does creating a config from scratch completely eliminate your issue to the point where you have noticeable change?