XIM Community

[ACTIVE] My Mouse turn on but won't work (I'm using a Xim4 on Xbox one)  (Read 262 times)

Offline Christianjordan

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: FamousJupiter40
I already update it and reset it and try it on pc and it worked just fine
« Last Edit: 04:41 PM - 10/09/18 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58613
    • View Profile
Welcome to the community. Which mouse brand+model are you using?

Please verify you're using the correct port order.

port 1: mouse
port 2: keyboard
port 3: controller

If this order does not work try reversing the mouse and keyboard cable positions at XIM.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Christianjordan

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: FamousJupiter40
Hi there yeah I put them in that order and I try the other way too.. I'm using a Marvo keyboard and mouse set. Is brand new I just get it yesterday

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58613
    • View Profile
Thanks for that information. It sometimes helps high power setups to start with only the controller attached. To test this first disconnect XIM and only leave the controller attached. After XIM has finished starting up attach the mouse to port 1 then test in game. If it works then attach the keyboard to port 2 and test.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Christianjordan

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: FamousJupiter40
Hi try it and it doesn't work, when I put the xim4 manager app I can see how the xim4 is connected with my keyboard Xbox one and controller but not with the mouse,they all are wired to it, is like it doesn't recognize it something but the mouse's lights turn on

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58613
    • View Profile
If connecting one device at a time after startup doesn't help it may be that these are not compatible or they are drawing too much power.

Earlier you had mentioned that you had you updated it. If you're referring to Manager this doesn't affect hardware support. XIM4's firmware would need to be updated, this is a manual update that requires a PC or Mac. I would try this next if you haven't. You can find the latest XIM4 firmware below. Please read the instructions on the download page.

http://community.xim.tech/index.php?topic=49093.0

Also, I found your mouse on the hardware list under not working. This means another user has reported this device as not working with XIM4. You could continue to test against a power issue if you would like by using a powered hub. Connect a hub between XIM and your peripherals, connect the hub's AC adapter into a wall to provide additional power. This helps with some high power setups. If updating the firmware and the power adapter suggestion do not help then I recommend using devices that are not under the not working section of the XIM4 hardware list:

https://community.xim.tech/index.php?topic=32933.0
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Christianjordan

  • Member
  • *
  • Posts: 4
    • View Profile
  • Gamertag: FamousJupiter40
Yes I already did the manual update with the computer,  I try a different mouse (a regular one) and it worked so I guess the one I have is not compatible?

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58613
    • View Profile
It's either not compatible or it's related to the amount of power your setup is drawing.  If updating the firmware and the power adapter suggestion do not help then I recommend using other peripherals.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos


Admin