XIM Community

[RESOLVED] XIM4 intermittently doesn't recognize mouse movements  (Read 113 times)

Offline sentx

  • Member
  • *
  • Posts: 9
    • View Profile
I haven't used my XIM4 for about 6 months.

Updated the latest firmware, plugged it to my PS4PRO, fired up Black ops 3.

However when I move my mouse sometimes it just doesn't do anything. This happens very frequently though, in 60 seconds gameplay, it happens at least 3 times or more.

It gets stuck and once it stucks whatever I do with my mouse it doesn't register at all, this can be like 1-2 seconds. Then it starts moving again normal, but still feels a bit sluggish. However keyboard works fine, mouse clicks are fine as well. I created a brand new profile, no changes.

Is there any idea why this might be happening?
« Last Edit: 10:56 AM - 06/15/18 by mist4fun »

Offline playlogitech

  • Member
  • *
  • Posts: 35
    • View Profile
Re: XIM4 intermittently doesn't recognize mouse movements
« Reply #1 on: 07:36 AM - 06/14/18 »
Check your usb cables and make sure your connected gamepad is fully charged

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45349
    • View Profile
Re: XIM4 intermittently doesn't recognize mouse movements
« Reply #2 on: 08:09 AM - 06/14/18 »
Usually when there is an issue with only one device it indicates an issue with that device. Which mouse is this? I recommend testing another mouse, even an office mouse would help in testing.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline sentx

  • Member
  • *
  • Posts: 9
    • View Profile
Cables are fine and controller is charged.

I've done more testing and it seems like when I use keyboad and mouse it freezes mouse. As if to many commands clogged the system.

If I don't press any keys on the keyboard it works fine. When I start using keyboard, strafe etc. and mouse then it stops mouse movements briefly. And when I stop using keyboard it works again.

Mouse: Razer deathadder
Keyboard: Microsoft Natural Ergonomic Keyboard 4000

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45349
    • View Profile
That's really strange, I haven't heard of this issue being reported before. If you do the same using the controller while attached to XIM does the same issue occur? In this case I would test another keyboard next.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline sentx

  • Member
  • *
  • Posts: 9
    • View Profile
Tried with controller while connected to XIM. No it works fine, I also tried keyboard and controller, that works fine as well. Doesn't cause that problem

Offline sentx

  • Member
  • *
  • Posts: 9
    • View Profile
I'm an idiot. Turns out mouse was indeed faulty. Not sure when that happened but another mouse works fine.

Thanks,

Online mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45349
    • View Profile
I'm glad that helped, thanks for updating your thread.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos