XIM Community

Joy-Con lagging or responsive  (Read 547 times)

Offline piiwii

  • MVP
  • *
  • Posts: 1898
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #15 on: 05:32 PM - 06/07/18 »
Thanks piiwii, the issues you are describing is because we aren't able to access the built-in unique calibration present in every Joycon. So, we have to infer it at runtime. Your script gets around that. Can you tell me if each person that uses it have to adjust numbers to make it work best with their joycon?

I’m not sure as I only have two Joy-Cons to test.

The value probably covers most. What I did was I started at about 95% and slowly worked my way down until I never got the issue again with either of my two Joy-Cons, that’s how I settled with 75%.
Setup: XIM Apex, Titan Two, Switch Joy-Con, Logitech G502, Razer mouse bungee, SteelSeries 4HD mousepad, DXRacer armrest, LucidSound LS30 headphones, Netduma router, Ubiquiti UniFi AP LR wireless access point

My setup (incl. Joy-Con mount): https://bit.ly/2jic7bG

My RAINBOW SIX SIEGE Titan Two Mega Script: https://youtu.be/x-9NtxyySVM

What is a ballistic curve? Click here to learn more: https://bit.ly/2qzUAjg

Using a Nav? Frustrated by the lack of buttons? See here: https://bit.ly/2JINRuB

Find me on the ConsoleTuner (Titan Two) forums: pablosscripts

Offline piiwii

  • MVP
  • *
  • Posts: 1898
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #16 on: 08:01 PM - 06/07/18 »
Ok all done, here is my Titan Two script translated into Titan One code (which Cronus Max uses):

Code: [Select]
int sprint_threshold = -75;

main {

// Inner deadzone
if(abs(get_val(PS4_LY)) > 5.00 && abs(get_val(PS4_LY)) < 15.00) {
set_val(PS4_LY, 0.0);
}
if(abs(get_val(PS4_LX)) > 5.00 && abs(get_val(PS4_LX)) < 15.00) {
set_val(PS4_LX, 0.0);
}

// Outer deadzone
if(get_val(PS4_LY) <= sprint_threshold) {
set_val(PS4_LY, -100);
}
if(get_val(PS4_LY) >= sprint_threshold * -1.00) {
set_val(PS4_LY, 100);
}
if(get_val(PS4_LX) <= sprint_threshold) {
set_val(PS4_LX, -100);
}
if(get_val(PS4_LX) >= sprint_threshold * -1.00) {
set_val(PS4_LX, 100);
}
}
Setup: XIM Apex, Titan Two, Switch Joy-Con, Logitech G502, Razer mouse bungee, SteelSeries 4HD mousepad, DXRacer armrest, LucidSound LS30 headphones, Netduma router, Ubiquiti UniFi AP LR wireless access point

My setup (incl. Joy-Con mount): https://bit.ly/2jic7bG

My RAINBOW SIX SIEGE Titan Two Mega Script: https://youtu.be/x-9NtxyySVM

What is a ballistic curve? Click here to learn more: https://bit.ly/2qzUAjg

Using a Nav? Frustrated by the lack of buttons? See here: https://bit.ly/2JINRuB

Find me on the ConsoleTuner (Titan Two) forums: pablosscripts

Offline tigerstick

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #17 on: 10:01 PM - 06/07/18 »
Thank you very much !  The script is complied successfully.   I tried for an hour, the irresponsiveness happenned less often.  But it still lag !  It can lag up to a second. It is so frustrated.  I hope Xim will fix it soon.

Thank you for your help !

Offline piiwii

  • MVP
  • *
  • Posts: 1898
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #18 on: 10:34 PM - 06/07/18 »
This is what it will fix: the loss of movement, inability to sprint, everything becoming slow.

This is what it won't fix: interference...make sure there is a clear line of sight between your Joy-Con and XIM Apex. Even a leg will cause issues.

I'm positive that if there's no line of sight interference, my script will 100% fix your issue.
Setup: XIM Apex, Titan Two, Switch Joy-Con, Logitech G502, Razer mouse bungee, SteelSeries 4HD mousepad, DXRacer armrest, LucidSound LS30 headphones, Netduma router, Ubiquiti UniFi AP LR wireless access point

My setup (incl. Joy-Con mount): https://bit.ly/2jic7bG

My RAINBOW SIX SIEGE Titan Two Mega Script: https://youtu.be/x-9NtxyySVM

What is a ballistic curve? Click here to learn more: https://bit.ly/2qzUAjg

Using a Nav? Frustrated by the lack of buttons? See here: https://bit.ly/2JINRuB

Find me on the ConsoleTuner (Titan Two) forums: pablosscripts

Offline tigerstick

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #19 on: 11:12 PM - 06/07/18 »
The distance between Xim Apex and Joy-Con is about 1.5m and there is nothing between them, is it too far ?

I will try again.


Offline piiwii

  • MVP
  • *
  • Posts: 1898
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #20 on: 11:27 PM - 06/07/18 »
Nope that should be fine.

Sometimes I have my legs crossed and my foot or thigh might come between the two, then I get lag. The moment I put my feet down the lag disappears.
Setup: XIM Apex, Titan Two, Switch Joy-Con, Logitech G502, Razer mouse bungee, SteelSeries 4HD mousepad, DXRacer armrest, LucidSound LS30 headphones, Netduma router, Ubiquiti UniFi AP LR wireless access point

My setup (incl. Joy-Con mount): https://bit.ly/2jic7bG

My RAINBOW SIX SIEGE Titan Two Mega Script: https://youtu.be/x-9NtxyySVM

What is a ballistic curve? Click here to learn more: https://bit.ly/2qzUAjg

Using a Nav? Frustrated by the lack of buttons? See here: https://bit.ly/2JINRuB

Find me on the ConsoleTuner (Titan Two) forums: pablosscripts

Offline tigerstick

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Joy-Con lagging or responsive
« Reply #21 on: 11:25 AM - 06/10/18 »
I tried the beta version of the firmware and phone app.  It seems it fixed the problem.