XIM Community

[ACTIVE] inconsistent connection issues  (Read 103 times)

Offline Griffinsi

  • Member
  • *
  • Posts: 6
    • View Profile
[ACTIVE] inconsistent connection issues
« on: 11:16 AM - 04/16/18 »
I'm unsure of how to go about setting up my XIM Apex daily. I did the initial setup and have used it multiple times since, but it seems hit or miss whether or not I'll connect first go upon starting my PS4. The procedure I carry out is as follows:

1. I unplug my XIM.
2. I start my PS4 using the middle button on the dualshock controller.
3. I plug in the XIM Apex with mouse, keyboard and controller all connected.
4. I turn on bluetooth on my android and connect via Apex manager app.

This connects succesfully judging by the changing colours upon changing configs. The HUD shows a wireless controller, keyboard and mouse respectively. I have also confirmed that there are no issues with the cable connecting the XIM to the controller.
« Last Edit: 12:45 PM - 04/16/18 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45350
    • View Profile
Re: inconsistent connection issues
« Reply #1 on: 12:45 PM - 04/16/18 »
Ideally the controller should be off before XIM is connected to the console. Start the console using the physical power button on the front of the console instead. More on this is in the start video:

http://xim.tech/start

I would start by connecting the controller directly with the console to charge for 1 hour. XIM should be disconnected while charging. Then try starting APEX as shown in the video linked above. If you still experience issues after this it would help to know more about your setup and the following questions.

1) When experiencing a startup issue do you see a controller/console icon at the top of Manager?
2) When experiencing a startup issue do you see a set of 4x green lights at the end of the startup light sequence? The light sequence should look like this:

red, green, blue
red
cyan, green
red
green, green, green, green

3) Could you please share your setup so we can learn more about the issue?

mouse:
keyboard:
extras: third party hub, switch, extended cables, titan, cronus?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Griffinsi

  • Member
  • *
  • Posts: 6
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #2 on: 12:56 PM - 04/16/18 »
Whenever I turn on the XIM with the controller off, I cannot turn on the controller while it's connected to the XIM, I must unplug it before I can turn it on. No I do not see 4x green lights. I see red, yellow, green, cyan, blue, then breathing red. As I connect to XIM manager I see red, cyan, blue, then 4x white light flashes as it connects.

Yes I do see the controller icon in the HUD even while the mouse and keyboard aren't working. I'm using a dell mouse and keyboard which have worked for me in the 3 days up to this

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45350
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #3 on: 01:01 PM - 04/16/18 »
Thanks, and to verify your controller is attached to port 3 on the hub? If so there is a communication issue between the controller and console, if charging the controller direct with the console doesn't help then you may need to replace the controller cable.

We can also check for a hub issue. Could you disconnect APEX, remove the hub, connect the controller directly to APEX, then connect APEX to the console? Do you see the 4x green lights at the end of the startup sequence?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Griffinsi

  • Member
  • *
  • Posts: 6
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #4 on: 01:12 PM - 04/16/18 »
I finally got it to connect, by first opening XIM Manager, THEN plugging in the XIM Apex. Is this sequence of events absolutely necessary in order to enable mouse and keyboard functionality? As opposed to Plugging in the XIM Apex, then opening XIM Manager

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45350
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #5 on: 01:36 PM - 04/16/18 »
No, Manager isn't necessary to use XIM once a config has been added. That may be a coincidence. Are you saying that you were unable to use Manager if opened after APEX is powered on?
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos

Offline Griffinsi

  • Member
  • *
  • Posts: 6
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #6 on: 02:34 PM - 04/16/18 »
No. I was able to use manager. However I was unable to use mouse and keyboard

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 45350
    • View Profile
Re: [ACTIVE] inconsistent connection issues
« Reply #7 on: 03:00 PM - 04/16/18 »
That may have been a coincidence then. If it comes up again please see my last post so we can better understand and solve the issue.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos