XIM Community

[ACTIVE] Xim Apex - Ps Nav Controller Random Disconnect  (Read 370 times)

Offline fluxxx_tasy

  • Member
  • *
  • Posts: 21
    • View Profile
  • PSN ID: juizt
Randomly my Nav controller will stop working. The mouse still works and the controller connected works. Unplugging the Nav and reconnecting doesn't fix it. I have to unplug and replug the apex usb unit directly connected to the PS4 Pro to reset everything to get it working again, which is a pain (especially mid game) because my PS4 is about 5 feet away from me on the other side of my desk. Any thoughts. I try to keep my Nav controllers charged externally.
« Last Edit: 08:24 AM - 04/18/18 by mist4fun »

Offline lmulli

  • Member
  • *
  • Posts: 169
    • View Profile
Re: Xim Apex - Ps Nav Controller Random Disconnect
« Reply #1 on: 07:42 AM - 04/18/18 »
Had the same issue last night.  Has to unplug the Xim from the PS4 a few times before it finally managed to pick the Navigation controller up. Also noticed that the Xim manager failed to connect to the Apex, which its been doing a few times of late, although it does eventually come round to connecting, either with persistent clicking on connect or unplugging the Apex.

Clearly there are issues somewhere, but thankfully, only every now and then! (just happens to be at that crucial moment in game!)

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 47508
    • View Profile
Re: Xim Apex - Ps Nav Controller Random Disconnect
« Reply #2 on: 08:23 AM - 04/18/18 »
Randomly my Nav controller will stop working. The mouse still works and the controller connected works. Unplugging the Nav and reconnecting doesn't fix it. I have to unplug and replug the apex usb unit directly connected to the PS4 Pro to reset everything to get it working again, which is a pain (especially mid game) because my PS4 is about 5 feet away from me on the other side of my desk. Any thoughts. I try to keep my Nav controllers charged externally.

The nav is prone to a few things that cause stability issues like this such as:

- a faulty cable
- a faulty nav port
- a low or weak charging battery

It's always recommended to fully charge the nav by attaching it direct to the console for 2-3 hours to charge. With a full charge, let's see if you have this issue with the nav in wireless mode, this will troubleshoot against all of these nav issues.

NAV off
XIM off
Controller in XIM Port 3 "..."
NAV in XIM Port 1 "."
XIM on
Connect manager and make sure NAV shows up
Unplug NAV
Confirm wireless NAV shows up in manager

Play for a while in this configuration and let us know if you experience a disconnect.
Have a problem with your XIM4? Find a solution in the XIM4 Support FAQ
XIM4 User Manual   |   XIM Instructional Videos