XIM Community

1000Hz slow input issue  (Read 1064 times)

Offline LITHE

  • Global Moderator
  • Member
  • *
  • Posts: 311
  • Instagram @gregrosolowski
    • View Profile
  • Gamertag: Kent C Strait
1000Hz slow input issue
« on: 06:47 AM - 03/23/18 »
After never getting my waiting list email I finally got my hands on the APEX!

1000Hz polling, holy crap is it responsive! But it appears it has some major drawbacks as well. The first ST I'm setting up is BF1, because on XIM4 it works super solid. But at 1000Hz, Fine movements are pretty difficult, its actually unplayable for me. I know about the smoothing trick, I have it set to 8. Medium, and fast movements are excellent! It's not even the "boxy" low resolution feel that bothers me in micro adjustments, its when i move the mouse extremely slow to make per pixel adjustments, it wont even pick up the input at times! I was able to very slowly move the mouse a half inch and have it register no input. On XIM4, and APEX default polling this is not an issue whatsoever. I tried both a hard razer mousepad and a cloth Steel Series pad with no noticeable difference.

Is there any sort of fix to this?

Below are my settings:

Battlefield 1

Hip 60

ADS 40

Smoothing 8

Uniform Aiming ON, 133 coefficient (same issues when turned off)

Razer Mamba wireless, 16,000 dpi

1000Hz

XBOX ONE X

Offline GitGud

  • MVP
  • *
  • Posts: 558
  • THE PUBG GOD
    • View Profile
Re: 1000Hz slow input issue
« Reply #1 on: 07:21 AM - 03/23/18 »
After never getting my waiting list email I finally got my hands on the APEX!

1000Hz polling, holy crap is it responsive! But it appears it has some major drawbacks as well. The first ST I'm setting up is BF1, because on XIM4 it works super solid. But at 1000Hz, Fine movements are pretty difficult, its actually unplayable for me. I know about the smoothing trick, I have it set to 8. Medium, and fast movements are excellent! It's not even the "boxy" low resolution feel that bothers me in micro adjustments, its when i move the mouse extremely slow to make per pixel adjustments, it wont even pick up the input at times! I was able to very slowly move the mouse a half inch and have it register no input. On XIM4, and APEX default polling this is not an issue whatsoever. I tried both a hard razer mousepad and a cloth Steel Series pad with no noticeable difference.

Is there any sort of fix to this?

Below are my settings:

Battlefield 1

Hip 60

ADS 40

Smoothing 8

Uniform Aiming ON, 133 coefficient (same issues when turned off)

Razer Mamba wireless, 16,000 dpi

1000Hz

XBOX ONE X

Try updating to the new beta firmware and try one of the other boost settings. Boost 3 is the default stock apex firmware. I personally still use stock firmware because I haven't experienced any issues but some other people have and what they did is update the firmware to resolve it.
My Current Setup + CouchMaster Review | PUBG Config | Warface Config | XIM Apex | Xbox One X |
SteelSeries Rival 600 | SteelSeries Dex | SteelSeries Apex M500 | SteelSeries Siberia 800 | Turtle Beach Stream Mic | 27' iiyama G-Master | CouchMaster Cycon

Offline GuNStArHeRo

  • MVP
  • *
  • Posts: 1186
    • View Profile
    • Subscribe
  • Gamertag: x GuNStArHeRo
  • PSN ID: GuNStAr-HeRo-
Re: 1000Hz slow input issue
« Reply #2 on: 07:27 AM - 03/23/18 »
waot are you using 16000 dpi and still need to have Hip 60 ADS 40?
XIM: 3/Edge/4/Apex | Titan: One/Two | XiM Link | PC: i7700k 1080ti ftw3 | M: Console: G502 - PC: fianlnouse Cape Town UL2 | KB: by the day and mood (60% to 65%) | Mouse Pad: by the day and mood (X-Large) | Audio/Mic: GoXLR | PC Mic: Shure SM7B | Monitor: 24" BenQ Zowie xl2436

Offline LITHE

  • Global Moderator
  • Member
  • *
  • Posts: 311
  • Instagram @gregrosolowski
    • View Profile
  • Gamertag: Kent C Strait
Re: 1000Hz slow input issue
« Reply #3 on: 04:11 PM - 03/23/18 »
Try updating to the new beta firmware and try one of the other boost settings. Boost 3 is the default stock apex firmware. I personally still use stock firmware because I haven't experienced any issues but some other people have and what they did is update the firmware to resolve it.

Do you have a link to the download? I checked the downloads and beta pages and couldn't find anything on the APEX.

Edit: Nevermind, found it! http://community.xim.tech/index.php?topic=63286.0

Changing boost settings haven't fixed this issue for me...

waot are you using 16000 dpi and still need to have Hip 60 ADS 40?

Yes, under 1000Hz polling. Under default settings and using XIM4 its usually around 5 to 10. Is this not normal? I'm a lower sensitivity player, center of mousepad to the edge is a little over a 180 degree turn on a pretty large pad.
« Last Edit: 04:33 PM - 03/23/18 by LITHE »

Offline LITHE

  • Global Moderator
  • Member
  • *
  • Posts: 311
  • Instagram @gregrosolowski
    • View Profile
  • Gamertag: Kent C Strait
Re: 1000Hz slow input issue
« Reply #4 on: 07:45 PM - 03/23/18 »
Issue is completely resolved with the new beta firmware! Thanks Kahun!

I also no longer need to increase my sensitivity, and don't feel any need for smoothing.

Hip is now 7.5, ADS is 2.5
« Last Edit: 08:34 PM - 03/23/18 by LITHE »

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 37870
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: 1000Hz slow input issue
« Reply #5 on: 10:13 PM - 03/23/18 »
Thanks for your feedback! By the way, you can always get to the latest Beta with this link: http://xim.tech/beta
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.