XIM Community

Apex Sensitivity Messed up Now?  (Read 125 times)

Offline Demons

  • Member
  • *
  • Posts: 18
    • View Profile
  • Gamertag: Almond
Apex Sensitivity Messed up Now?
« on: 12:37 AM - 03/14/18 »
Got my apex today hooked it up and played some games of fortnite. My mouse is a Logitech G502 Set to 12000 dpi. I set the polling rate on my Mouse to like 500 then connected it to my xim. I followed all the steps and turned my in game setting all the way up. I had the sensitivity in the xim app to like 11 and it was quite fast but now to get my sens fast I have to turn the sensitivity all the way to like 50!
Please tell me what I did wrong and how to go back to what it was when I first got it/started playing.

Offline High Sensitivity Needs

  • Member
  • *
  • Posts: 8
    • View Profile
Re: Apex Sensitivity Messed up Now?
« Reply #1 on: 12:45 AM - 03/14/18 »
Havenít been a user for long but we have the same mouse. Make sure you didnít move a decimal in your configuration app, or change your dpi profile from the side buttons. Also be sure to update settings back to recommended in game each log in for certain games.

Offline antithesis

  • MVP
  • *
  • Posts: 5697
    • View Profile
Re: Apex Sensitivity Messed up Now?
« Reply #2 on: 01:44 AM - 03/14/18 »
When changing Apex polling rates, read the notice that appears in Xim Manager. Unplug then replug the Apex to propagate the change, which also requires multiplying your original sens values by 8 if you changed the polling rate from 125 to 1000Hz.