XIM Community

Apex w/ powered USB switch odd behavior  (Read 294 times)

Offline SomeZero

  • Member
  • *
  • Posts: 54
    • View Profile
  • Gamertag: SomeZer0
Apex w/ powered USB switch odd behavior
« on: 06:27 PM - 03/08/18 »
Setup
G502
Razer black widow mechanical
Into IOGEAR 4 Port powered USB switch
Then switch and Xbox controller into provided 4 Port huB
Then apex into back of Xbox

Ive been a commander then sandhawC user ever since I got my first Xim and when the new client is released I'll be back.

This may be normal behavior so delete if it necessary. All is fine for a while but if I switch to PC controls for 10-15 minutes when switching back power does not return to the keyboard and mouse (lights) and only the controller is responsive. All cables are high-quality braided it is just as iif the Xim is off but lights remain on the unit. A quick unplug and replug solves the issue.

Again this is a temporary setup so I'm not concerned I figured I'd report if it helps and check if I'm missing something obvious.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 54643
    • View Profile
Re: Apex w/ powered USB switch odd behavior
« Reply #1 on: 06:31 PM - 03/08/18 »
I'm not familiar with the quirks of using a switch with XIM but from what I understand your mileage will vary by the switch used and your hardware setup. I had these issues years ago using a switch with XIM3. This made me pickup a wireless keyboard and a second mouse, problem solved. :)

I think antithesis and piiwii use a switch, I recommend talking with them about their experience.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos


Admin