XIM Community

Ps Nav Issues  (Read 471 times)

Offline correnmugica

  • Member
  • *
  • Posts: 11
    • View Profile
Ps Nav Issues
« on: 03:13 PM - 01/12/17 »
I have the xim4 works great have had it set up for months now. I never unplug the nav from the xim. I know you can connect bluetooth but i sit close enough i leave it plugged in. Since ive been using it the nav stays plugged and doesnt have lights or flash at all.  About a week a go the nav was unresponsive so to get the nav to come on and work i had to hit the ps button and then after It takes about 10 seconds for the xim to recognize and then will work for a short time then it will t urn off again. I tried charging the nav. Still the same issue. I have the latest beta firmware. Any ideas?

Sent from my SM-G935P using Tapatalk


Offline RML

  • MVP
  • *
  • Posts: 6939
  • AKA "KO" - PUBG Shield [ON]
    • View Profile
Re: Ps Nav Issues
« Reply #1 on: 05:22 PM - 01/12/17 »
Unfortunately part of the problem with the NAV is that they've been out of production for several years now. That means battery life is dwindling. That may or may not be your problem. However, you should always make sure your NAV is dead before recharging, just to make sure you get the most out of the battery.

Offline Loki

  • MVP
  • *
  • Posts: 650
    • View Profile
  • Gamertag: Loki Revamped
  • PSN ID: LokiRevamped
Re: Ps Nav Issues
« Reply #2 on: 07:37 PM - 01/12/17 »
Unfortunately part of the problem with the NAV is that they've been out of production for several years now. That means battery life is dwindling. That may or may not be your problem. However, you should always make sure your NAV is dead before recharging, just to make sure you get the most out of the battery.

+1, if you don't plan on using the wireless option, you can always take out the battery......that's what I did.
ping" width="200" height="200


Please don't trivialize something you don't understand