XIM Community

[SOLVED]Razer Naga 2014 - XIM failure to power up & mouse freezes  (Read 3043 times)

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Hey every one.
Glad to get into this community and congrats for the nice piece of equipment you guys made.
I bought a XIM4 recently but i am facing some problems.

Here are the facts:

  • Random mouse freezes of 3-10sec each time. (The keyboard works ok during the freeze)
  • I am using an old microsoft Sidewinder x4 keyboard  and a 2014 razor naga mouse.
  • Lights on mouse stay on while the freeze happens
  • The mouse works flawlessly on a PC, i ve been using it for more than a year without a single issue
  • Xim4 and M/K stay on while the ps4 is on rest mode (probably thats normal)
  • I cant turn the PS4 on from the PS button on the controller, i need to unplug the usb, press the button, then quickly reconnect it for the xim to boot.
  • I have only tried playing battlefield 4
  • Both manager and Firmware versions are 4.00.20160405
  • Tried some gameplay with an ancient Microsoft sub/ps2 mouse and didnt face any freeze in 30min of gameplay (not too long of testing though)

Please gimme some hints as to what i could look into.
I'd love to keep using the Naga, as the 12 side buttons are handy as hell in gameplay.

Looking forward to your advice,
Regards,
k.
« Last Edit: 04:36 AM - 10/28/16 by krasatoulis »

Online OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 41513
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #1 on: 10:49 AM - 10/20/16 »
Do you see your XIM4's lights doing anything when the freeze happens? Also, do you continue to see your mouse icon in Manager after it happens?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline JbowenDaMan

  • Member
  • *
  • Posts: 233
    • View Profile
  • PSN ID: JbowenDaMan
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #2 on: 11:36 AM - 10/20/16 »
What colors are the lights?


Sent from my iPhone using Tapatalk

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #3 on: 01:02 AM - 10/21/16 »
Thanks for the immediate replies.
I will test and come back to you asap.

Regards,
k.

Online OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 41513
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #4 on: 02:17 PM - 10/21/16 »
Thanks, let us know what you find.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #5 on: 11:24 AM - 10/22/16 »
Hello again,
Unfortunately im coming back with bad news.
Ill just explain the process step by step with the most detail i can:

  • Everything is connected to the XIM, PS4/Controller/K/M
  • I push the PS button on the controller and the PS4 boots (it seems to boot when the ps4 is completely off - in contrary to point #6 of the first post
  • The XIM does light up, goes through a sequence of colors and finally settles on a predefined purple i have set from the settings
  • The keyboard does not work - does not even light up (has some red backlight)
  • The mouse does not work - it does light up, (i have set it to illuminate some of the keys on the pc software which is saved on the mouse)
  • Cannot connect to the XIM through the mobile app, (BT is on on my phone) - Xim does not even appear on available BT devices.
  • Restarting the PS4, same things happen (this time i need to remove the usb from the controller upon boot though, to register the PS button press

Looked like a usb power shortage, so i fixed it by removing the second usb from the PS4 and the mouse and keyboard do boot ok now.
(i have a hdmi2vga adaptor which needs external usb power to work.)
The keyboard and mouse are now responsive, So is the XIM app, i can connect to it.

Pretty weird though, as the first 15days i used the XIM i had exactly the same setup. How can it suddenly need more power from the usbs?

Any thoughts on that would be nice.
Will go check gameplay with the mouse and try to bring answers to the questions you originally asked me guys.
Thanks again

Online OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 41513
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #6 on: 06:48 PM - 10/22/16 »
"I push the PS button on the controller and the PS4 boots (it seems to boot when the ps4 is completely off - in contrary to point #6 of the first post"

You should never press the PS button. Your XIM4 should be unplugged with your DS4 charged and off with your console on and initialized. Then, plug your XIM4 into your console and your DS4 should turn on automatically and you should see 4 quick green light flashes on your XIM4 after that.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: [help]New XIM4 - Random Mouse Freezes
« Reply #7 on: 06:29 AM - 10/23/16 »
Your XIM4 should be unplugged with your DS4 charged and off with your console on and initialized. Then, plug your XIM4 into your console and your DS4 should turn on automatically and you should see 4 quick green light flashes on your XIM4 after that.

*Still facing the same problems, kb/m wont boot, and cant connect with BT. removing the second usb as noted in my previous post was not a permanent solution it seems.*

So here are my steps:
PS4 is on, and the screen reads "Welcome back to Playstation, Press the PS button to use the controller"
DS, K & M are connected to the XIM, XIm is not connected to PS4, DS is off.
I connect the XIM to the PS4, i get a rainbow sequence on XIM, then finally a green color for a split seccond then it stops at purple breathing (which is the predefined color i set).
The DS flashes orange and then nothing. (i guess its for getting charge)
PS4 remains on the previous message screen asking for PS button to be pressed but the DS is off.

That's all, the keyboard does not respond, the mouse does not respond, i cant connect with the app to the XIM.

Thanks for the support OBsIV , but it seems like im doing somehting wrong... it worked fine for 2-3 weeks... now it refuses to do so :(

Please let me know of other things to check.
Looking forward to your reply,
Regards,
K.
« Last Edit: 06:34 AM - 10/23/16 by krasatoulis »

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Random Mouse Freezes at start, now cant Initialize XIM4
« Reply #8 on: 07:33 AM - 10/23/16 »
Update:

I seem to have narrowed down the problems to the Naga mouse.
Nothing works when it's plugged in, and when i unplug it, the Keyboard lights up, Bluetooth connects etc.

I guess the easy answer is to use another mouse but, those extra keys on the naga are something i wouldnt like to miss.
There should be some settings that would allow it to work, as it is on your compatibility list and other users report it working.

I read somewhere on these forums that the polling rate of the mouse should not be 1000 so i lowered it to 500.
I also tried turning off all the leds on the mouse for power economy.
I have Acceleration set to 0
And there is no DPI setting, only Sensitivity, ranging from 100 to 8200.

Any ideas on how to make it work?

Again, Thanks in advance.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58071
    • View Profile
Re: Random Mouse Freezes at start, now cant Initialize XIM4
« Reply #9 on: 09:52 AM - 10/23/16 »
Polling rate or any other onboard mouse setting wouldn't break support like this.

It could be power, support, or the mouse itself. You can troubleshoot the first two by disabling the naga LEDs to lower the power load. I don't think you've mentioned which firmware version you are using? There is a new beta firmware which improves hardware support in Release Candidates. This is newer than what you will find in the download section. I would update to it if you're not already using it.

You can find the latest beta build by visiting the Release Candidates section of the forum linked below. Please read the installation instructions included in the download threads.

http://xim4.com/community/index.php?board=77.0
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Random Mouse Freezes at start, now cant Initialize XIM4
« Reply #10 on: 01:44 PM - 10/23/16 »
Polling rate or any other onboard mouse setting wouldn't break support like this.

It could be power, support, or the mouse itself. You can troubleshoot the first two by disabling the naga LEDs to lower the power load. I don't think you've mentioned which firmware version you are using? There is a new beta firmware which improves hardware support in Release Candidates. This is newer than what you will find in the download section. I would update to it if you're not already using it.

You can find the latest beta build by visiting the Release Candidates section of the forum linked below. Please read the installation instructions included in the download threads.

http://xim4.com/community/index.php?board=77.0

Hey mist4fun, thanx for the input.
Tried disabling the leds on the mouse, no luck.
Both manager and firmware versions are 4.00.20160405

I will go ahead and try the RC version but what is strange is that for two weeks the whole setup worked flawlessly...
Then suddenly mouse freezes and now this - the only thing i changed is probably some of the mouse settings, regarding sensitivity and refresh rate, but i reverted them back with no luck.

Will check the RC tomorrow and come back to you guys.
Thanx for the support!

Regards,
k.

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Random Mouse Freezes at start, now cant Initialize XIM4
« Reply #11 on: 10:30 AM - 10/24/16 »
Update:
The non-initialization issue seemed to be a power shortage, i hooked up an old, powerd usb hub on XIM and the mouse and keyboard now work.
Why that power shortage happened suddenly is a mystery to me, as the combination of hardware used to work fine for the first two weeks when i bought the xim.
If anyone could chip in some ideas it would be nice.

Unfortunately i am back to square one, Although the m/k work and the system initalizes as intended, i am back to having the occasional mouse freezes as described in my first post of the thread.

I have not yet flashed the RC version of firmware as mist4fun suggested but will do so and report back.

Once again thanks for the support guys, i hope we can get to the bottom of it soon.

Regards,
k.
« Last Edit: 02:56 PM - 10/24/16 by krasatoulis »

Offline krasatoulis

  • Member
  • *
  • Posts: 10
    • View Profile
Re: Random Mouse Freezes at start, now cant Initialize XIM4
« Reply #12 on: 04:34 AM - 10/28/16 »
To sum up:

This whole issue seemed to be caused by the Naga 2014 mouse.
Although it seemed to work fine for the first 10 days, the whole thing started falling appart day by day (cant really explain it)

I fixed it with a powered usb hub and upgrading to a beta firmware version as proposed above.
I also switched from bf4 to bf1 (as the game i mainly play)
Right now i have three consecutive days of online gameplay without a single issue and it's put a smile on my face.

(ill change the title of the thread to better reflect the issue, for the rest of the community)

Thanx for the support and interest, hope i wont bother you about this anymore.
Regards
k.

Offline F4LL3N1

  • Member
  • *
  • Posts: 26
    • View Profile
I get it from time to time using Logitech G190 mech KB and Razer Deathadder.
Fully charge your DS4 controller and try again, happens when I've had PS4 off for long periods.
Keep it in rest mode after you finish gaming, and disable lights if you can. Some gaming
gear has onboard memory, if you save your profile with lights disabled as default works too.

Hope it helps, I tried a Naga and returned it as it wouldn't work. Too much power draw  :( 

Online antithesis

  • MVP
  • *
  • Posts: 12603
    • View Profile
    • Mod Squad
This is not uncommon for Razer mice. I had this problem for years before realising Xim supports USB hubs.

Plug the mouse (and optionally, keyboard) into a powered USB 2.0 hub. Plug the hub into the Xim. Xim into console. Boom. Done. No more disconnects and the mouse should feel smoother.

Even better, ditch Razer mice altogether and go with Logitech - they're less power-hungry and the sensors work better with Xim.

Official Australian distributor for XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts