XIM Community

Xtrfy XG1-R Led, mechanical keyboard  (Read 674 times)

Offline Raz69

  • Member
  • *
  • Posts: 7
    • View Profile
Xtrfy XG1-R Led, mechanical keyboard
« on: 07:09 AM - 09/22/16 »
Hi , does anyone know if this keyboard work with xim 4 ?

http://xtrfy.com/product/xg1-r-led/

Offline Raz69

  • Member
  • *
  • Posts: 7
    • View Profile
Re: Xtrfy XG1-R Led, mechanical keyboard
« Reply #1 on: 02:57 AM - 09/26/16 »
I bought this keyboard this weekend but it doesnt work the lights are just flashing on the keyboard and xim doesnt work either, il guess i have to buy a USB hub with ac power adapter

i also bought logitech g502 - worked perfect even the sniper button worked perfect right out of the box, i just connect it to the pc and installed LGS and set the dpi settings... just need to play withe mouse to get used to it.

im gonna buy this one today and try tonight again

D-Link 4-Portar USB-Hub DUB-H4 (USB 2.0) with ac adapter

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 52312
    • View Profile
Re: Xtrfy XG1-R Led, mechanical keyboard
« Reply #2 on: 09:02 AM - 09/26/16 »
Are you using the latest beta firmware which improves hardware support? If not then here is a link.

You can find the latest beta build by visiting the Release Candidates section of the forum linked below. Please read the installation instructions included in the download threads.

http://xim4.com/community/index.php?board=77.0
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline Raz69

  • Member
  • *
  • Posts: 7
    • View Profile
Re: Xtrfy XG1-R Led, mechanical keyboard
« Reply #3 on: 11:32 PM - 09/26/16 »
Last night i tried to connect My iOS devices to xim and It didnt worked, the xim manager told me my firmware was out of date, so i downloaded 20160405 and it worked again.

Then i connect the new USB hub to xim , connected Both mouse and keyboard to the hub, xim responded when i push the buttons and made the configuration, But nothing happens when i played .

Then i unplugged the mouse from hub and put it direct to xim. Finally everything works great :)

I forgot to try my logitech extreme 3D pro joystick, But il do it tonight. I Will also try to skip the hub now that i have updated the firmware.

Thanks
« Last Edit: 12:48 AM - 09/27/16 by Raz69 »