XIM Community

"Floatiness" feel after a bit of playing.  (Read 829 times)

Offline Sprint

  • Member
  • *
  • Posts: 77
    • View Profile
"Floatiness" feel after a bit of playing.
« on: 02:10 PM - 05/23/16 »
Hey ximers. I have been having this issue for a while but never knew what was really happening.

Basically after a bit of playing (an hour or so) the mouse movement feels less and less 1-1 and more "floaty" and "sluggish". Not sure of other adjectives to describe it. However, I learned that if i unplug my mouse and plug it back in, it will sometimes help. Or if i unplug my XIM and plug it back in, it will sometimes help.

Was just wondering if anyone else had this issue.

It is not the mouse as I have tried on my Steelseries sensei, my logitech g9x, and my logitech g502 with the same results.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58824
    • View Profile
Re: "Floatiness" feel after a bit of playing.
« Reply #1 on: 03:28 PM - 05/23/16 »
This isn't typical, performance shouldn't degrade over time. Are you using the 20160405 build? Also, are you playing on a monitor or a tv?
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline Sprint

  • Member
  • *
  • Posts: 77
    • View Profile
Re: "Floatiness" feel after a bit of playing.
« Reply #2 on: 03:46 PM - 05/23/16 »
This isn't typical, performance shouldn't degrade over time. Are you using the 20160405 build? Also, are you playing on a monitor or a tv?

Both my manager and firmware version are 20151120. This is probably pretty old and i'll definitely do an update - hoping this is the issue. Also using a monitor incase thats relevant too.

edit: Would just like to ask - XIM will still work with IOS if i update?
« Last Edit: 04:19 PM - 05/23/16 by Sprint »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58824
    • View Profile
Re: "Floatiness" feel after a bit of playing.
« Reply #3 on: 04:43 PM - 05/23/16 »
Thanks for confirming. I just wanted to verify that you are on STv2 and you are, you shouldn't need to update for improved performance. Also playing on a monitor can ensure your input lag is low, its usually higher on larger displays and TVs. The most recent build, 0405, will flash purple lights if your performance is degraded. It also has improved logging. Are you an iOS user? If so you could PM Obsiv your email address for an invitation to testflight. Once you are invited you can install the 0405 Manager but you would still need to update your firmware to 0405 using a Windows PC. This could help us determine if there is anything wrong with your setup or XIM4.
« Last Edit: 04:53 PM - 05/23/16 by mist4fun »
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos