XIM Community

Connection (Sync) Issues  (Read 1198 times)

Offline KuzuRanger

  • Member
  • *
  • Posts: 127
    • View Profile
  • PSN ID: KuzuRanger
Connection (Sync) Issues
« on: 12:51 AM - 04/05/16 »
Since there are other threads like this, thought I would create a new one for my specific case. I cannot get a consistent connection with all 3 controllers (nav/mouse/DS4) when I start playing. In fact, most of the times it takes me a good 10+minutes to get it to finally sync properly. Here is what I'm doing:

1) Connect fully charged Nav to slot 1 (OFF)
2) Connect wired mouse to slot 2
3) Connect Dualshock to slot 3 (OFF)
4) Connect XIM to PS4 (OFF)
5) Boot up PS4 using console button (not PS button)
6) Let PS4 load up into XMB screen

Yes, I try pressing the PS button on Nav 1st, and occasionally that works. But for the most part, I have this strange combination of the Nav/mouse only functioning in my XMB menus but NOT in-game.

I wrote this elsewhere, but essentially nearly every night I have to go through serious hoops getting everything working. I don't recall having these problems with the Edge, or even with previous XIM4 games. It seems to happen alot with The Division, but of course that is purely subjective.

Not sure if relevant but I saw a similar thread with same connection issues; I'm using an amp for headphones (Astro A40) - using split power vs data cables to fix a buzzing issue. It seems like perhaps too much power is getting drained from the PS4 and causing these issues? If it helps, my PS does detect both "controllers"; the Dualshock and (I'm assuming) the Nav.

I guess I would just like to know if there is a super-intricate order, in addition to the order I used above, that I need to be testing out. It really has been bugging me lately since I lose gaming time each night having to deal with these setup issues. Any help/advice would be much appreciated. TYIA.



« Last Edit: 01:57 AM - 04/05/16 by KuzuRanger »
http://www.youtube.com/KuzuRanger

XIM4 / Razer Naga Hex / Move Nav x2 / Astro A40

Offline KuzuRanger

  • Member
  • *
  • Posts: 127
    • View Profile
  • PSN ID: KuzuRanger
Re: Connection (Sync) Issues
« Reply #1 on: 01:07 AM - 04/05/16 »
Today:

Steps 1-6. Pressed PS on Nav. Nav/Mouse connected and work in XMB menus. Start up game. On-screen prompt says "No dualshock controller is connected", so I press the PS button and it starts up. Dualshock is on, but nav/mouse do not function inside the game; no response at all.

I can press PS button on the nav to get back to XMB menu and it works there. Again, weird.
-------------------------
Then I held down PS button and turned off "All devices". Dualshock and mouse/nav are off. Unplugged USB from XIM4, plugged back in to restart the process. Same issue as above. Nav/mouse work in XMB menus, once I get into game it says Dualshock is not connected. Press PS button, dualshock is on/connected and works in game, but Nav/mouse buttons do not get a response in-game.
-------------------------
Ok so I tried these steps another 3-4 times, using different USBs and mini-USBs. It finally connected. I don't know if this is the fault of the cables or something else, but obviously I will use the same cables that work right now. If I have further problems, which honestly I'm expected the next time, I'll post again when I can.

FYI: now when I go into my "Adjust Sound and Devices" (where I previously went to turn all controllers off before resetting the process), there is no longer any option to turn off the controllers!? Weird.
« Last Edit: 01:34 AM - 04/05/16 by KuzuRanger »
http://www.youtube.com/KuzuRanger

XIM4 / Razer Naga Hex / Move Nav x2 / Astro A40

Offline KuzuRanger

  • Member
  • *
  • Posts: 127
    • View Profile
  • PSN ID: KuzuRanger
Re: Connection (Sync) Issues
« Reply #2 on: 01:52 AM - 04/05/16 »
More info:
I replaced 2 of the cables during this testing period yet I don't think that was the culprit for my issues. I put back one of the cables (USB) to my Nav<->XIM and it connected/worked properly. I used the other cable (mini-USB) and it is charging my phone via PC. This is why I cannot clearly say with satisfaction that replacing cables was the answer. As I do most nights, I have to keep unplugging, plugging in, turning off, turning on in an endless loop to get things working, which is the same as tonight.

Anyone have similar issues?
http://www.youtube.com/KuzuRanger

XIM4 / Razer Naga Hex / Move Nav x2 / Astro A40

Offline Od1n

  • Global Moderator
  • MVP
  • *
  • Posts: 34409
    • View Profile
Re: Connection (Sync) Issues
« Reply #3 on: 07:31 AM - 04/05/16 »
hey,

here are a few things id test

1) use the nav in wireless mode with the xim so less power is consumed
requires latest xim beta firmware, if you are not running this version definitely upgrade

2) exchange the usb cable between xim - ps4
for a first try you might to change it with the cable between xim - dualshock 4 controller

3) detach some of your gear from the xim so only one thing at a time is connected
try to identifiy if it happens again and what gear is attached
if everything works perfect in single mode then attach two things at a time

4) if 3) is too time consuming get an usb hub with external power supply which connects directly to the xim port 1
mouse and sony nav connect to the hub then

5) try a different ps4 usb port
PS5 & X1 | C: MS | XIM Apex & Nexus | FW: the latest ofc! :) | Mon: BenQ XL2420Z | Pad: Zowie G-SR | KB: Ducky DK1008L Cherry Red O-Rings| A: AKG K701 Creative X7 Antlion Modmic | M: Glorious Model O | D: 1800 | P: 1000hz | BF4 4 HIP: 35 ADS: 20

My Fortnite Creator Code: beamimpact
Check out my Youtube Channel: XIM Central

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58836
    • View Profile
Re: Connection (Sync) Issues
« Reply #4 on: 09:31 AM - 04/05/16 »
It sounds like your nav is connecting to your console if it works in the menu but not in game. Which build are you using? You can find the version numbers in menu->about of Manager, they start with 4.00.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline KuzuRanger

  • Member
  • *
  • Posts: 127
    • View Profile
  • PSN ID: KuzuRanger
Re: Connection (Sync) Issues
« Reply #5 on: 09:23 PM - 05/30/16 »
Follow up - just in case people are having the same issues.

I have been extra anal about charging Dualshock + Nav after every session. I also make sure to have EVERYTHING plugged in (and charged fully) before turning on PS4. Since then, I haven't had any issues at all.
http://www.youtube.com/KuzuRanger

XIM4 / Razer Naga Hex / Move Nav x2 / Astro A40


Admin