XIM Community

[ACTIVE] Xim4 Won't connect to Pc?  (Read 8676 times)

Offline Aiken_Drum

  • Support Staff
  • MVP
  • *
  • Posts: 4005
  • You talkin' to me?
    • View Profile
Re: [ACTIVE] Xim4 Won't connect to Pc?
« Reply #30 on: 12:13 PM - 01/12/15 »
That means to me that your bluetooth chipset and XIM4 simply aren't getting along in some way.  They do appear to have been paired, despite the extraordinarily long time spent pairing, or else the entry wouldn't be in your Devices & Printers list.  Theoretically, they should be able to talk to each other.  However, I'm assuming the long delay in pairing means something timed out and some form of fallback occurred, perhaps to an earlier version of the BT protocol or something.  We only support BT 2.1+ communications, so if that occurred, it might indeed appear to pair and then never actually communicate afterwards.

I think this simply has to be one of the Atheros variants we still don't work with.  Right now, the only solution to that is either to use wired configuration or to use another bluetooth device.  By "another bluetooth device," I mean the obvious stuff: either an add-on adapter for your PC, using a chipset that's been seen to work well with XIM4, or another device entirely, e.g. another PC with a different bluetooth chipset or an android phone/tablet.

Would you do me a favor, though?  I'd like to know the vendor and hardware ID of this particular chipset so I can look it up.  I want to start creating a list of Atheros variants that work and don't work, so we can skip back-and-forth sessions like you've just had with us.  So what I'd need you to do is the following, if you would:

  • Open Device Manager

  • Expand the Bluetooth Radios section

  • Right-click on your BT radio (note: not the one named Microsoft Bluetooth Enumerator) and select Properties

  • Select the Details tab

  • Set the drop-down list to Device Description and copy+paste the text from the box into a reply here

  • Set also to Hardware IDs and copy+paste that text into the reply as well

It's also possible that when I look it up, I might run across some errata about certain things working only in one particular version of the driver or something.  It's worth a try.

Offline iLikeTrees

  • Member
  • *
  • Posts: 31
    • View Profile
Re: [ACTIVE] Xim4 Won't connect to Pc?
« Reply #31 on: 07:14 PM - 01/12/15 »
Under Device description, it only says "ASUS Bluetooth"

 Hardware ID= "USB\VID_0B05&PID_179C&REV_0001"
"USB\VID_0B05&PID_179C"


 Could you tell me which of these I could purchase that would work 100%?
http://www.amazon.com/s/ref=sr_nr_p_85_0?fst=as%3Aoff&rh=i%3Aaps%2Ck%3Abluetooth+dongle%2Cp_85%3A2470955011&keywords=bluetooth+dongle&ie=UTF8&qid=1420950768&rnid=2470954011

Offline Aiken_Drum

  • Support Staff
  • MVP
  • *
  • Posts: 4005
  • You talkin' to me?
    • View Profile
Re: [ACTIVE] Xim4 Won't connect to Pc?
« Reply #32 on: 07:38 PM - 01/12/15 »
Thanks for the IDs, I'll take a look and see if I can find anything useful.

As for the adapters, I don't actually know which ones work consistently, since there are literally hundreds of them with multiple revisions or different internals with the same shell as time passes and component availability changes, so it'd be no simple task to keep track of them.  I personally use a no-name cheapo one that I had bought for an old Win7 tablet, so I can't even tell you what *I* use.  :)

However, if you post the same question on the XIM4 Discussion board, I can about guarantee you'll get some confirmations/suggestions about what will work.  You may even find results by searching.  I think I've seen Kinivo mentioned quite a few times, though I don't recall if that was "working" or "not working".

(Sorry, my organic memory sticks are long out of warranty. ;) )


Admin