XIM Community

What apps could be causing "Could not query mouse/keyboard" error?  (Read 1442 times)

Offline jackel1060

  • Member
  • *
  • Posts: 107
    • View Profile
  • Gamertag: Jackel 1060
I find that every once in a while (maybe once or twice per gaming session), my keyboard & mouse suddenly freeze, and when I switch the monitor back to the host PC, something has caused the XIM software to lose control, and the mouse/keyboard are in the Windows mode.  I can fix it easily by clicking back onto the XIM software window, but it's obviously not good that this happens at all.

I've tried to hammer on the keyboard and mouse while the XIM software is running to see if I can induce this, but have had no luck (sticky keys are off).  My best guess now is that some other program occasionally takes over the desktop for a few seconds, but then is unable to hand control back to the XIM program.  I notice this happens quite consistently while I'm waiting for Halo 3 to do matchmaking, so the keyboard & mouse is idle for maybe 30-90 secs.  The other strange thing is that it happens more often when playing Call of Duty Modern Warfare 2, almost always while the level is loading and keyboard & mouse are idle for a short time.

I've gone into my msconfig menu and am disabling everything I can.  My best guess is that it's a background updater program that pings the update server when the PC appears to be idle briefly.

My rig:
- Windows 7 64-bit Ultimate RC
- Keyboard & mouse are connected through a USB hub (I know this is not recommended, so will try going direct next, but does not seem to be a USB connectivity issue)
- Running Logitech Setpoint (have tried exiting it, but does not have any effect)

Suspected update apps which I am now systematically disabling:
Adobe Updater (updates PDF Reader and other Adobe apps)
Java Updater
Quicktime Updater

Any other pointers?  Is it possible that the XIM software will give up control of keyboard & mouse to Windows if one of these background update programs is running?

Thanks! Joe

Offline tweak

  • MVP
  • *
  • Posts: 2346
    • View Profile
How did you go about installing the XIM360 driver on your system?

Offline jackel1060

  • Member
  • *
  • Posts: 107
    • View Profile
  • Gamertag: Jackel 1060
How did you go about installing the XIM360 driver on your system?

I followed the instructions regarding turning off the driver signing, and installed the USB Xpress Install drivers.  It all seemed to work like a charm initially.

After turning off all the updating applications listed above, so far so good (2 nights with no hiccups).  I'll report back after a couple more days, and will list out all the apps that I de-activated using msconfig for the benefit of others in the community.

Thanks!

Offline Grimfear

  • Member
  • *
  • Posts: 1
    • View Profile
I'm running it on WIN7 RC still and it works fine. I've had that happen before. I think it has something to do with the game panel manager for my G15. I've only had that error happen twice in a couple of months. I just restart the xim software and it seems to work fine.

Offline pharrowboy

  • Member
  • *
  • Posts: 372
    • View Profile
are you running AVGfree anti virus software? the latest build causes any program to lose focus every 5 mins or every 30 mins. theres a fix for it on the avg forums

Offline jackel1060

  • Member
  • *
  • Posts: 107
    • View Profile
  • Gamertag: Jackel 1060
Yes, I am running AVG Free in fact!  Thanks, I've just installed the fix and will resume testing.  For those who are interested, the patch is available here:
http://forums.avg.com/us-en/avg-free-forum?sec=thread&act=show&id=40443

Will try to log some good hours this weekend and report back.

Offline Voli

  • MVP
  • *
  • Posts: 1119
    • View Profile
It just randomly started happening to me a lot lately too.. I just pressed alt+tab to bounce back to the window lol. I didn't know about how to search for this type of error and figured I was the only one having it. lol Ill check out this "fix"

Offline pharrowboy

  • Member
  • *
  • Posts: 372
    • View Profile
Yes, I am running AVG Free in fact!  Thanks, I've just installed the fix and will resume testing.  For those who are interested, the patch is available here:
http://forums.avg.com/us-en/avg-free-forum?sec=thread&act=show&id=40443

Will try to log some good hours this weekend and report back.

no problem

Offline jackel1060

  • Member
  • *
  • Posts: 107
    • View Profile
  • Gamertag: Jackel 1060
The AVG hotfix seems to be working so far.  I've played 3 evenings for about 2.5 hours continuously each time, zero issues with the XIM application losing focus.  So far looks like this was the root cause.

Offline Voli

  • MVP
  • *
  • Posts: 1119
    • View Profile
Yeah.. I forgot I was having this problem prior to the fix. Thanks much.