XIM Community

COD:AW on XB1 choppy in multiplayer  (Read 1609 times)

Offline heitczman

  • Member
  • *
  • Posts: 2
    • View Profile
COD:AW on XB1 choppy in multiplayer
« on: 09:59 PM - 11/27/14 »
I just received my XIM4 upgrading from my old XIM3. When I play online multiplayer, all of my aiming movements become choppy as if the game is dropping frames. it is more noticeable the slower I move my reticle. I started a local game against bots and the aiming is smooth again. The config is set properly and I just dbl checked my G500 to make sure it was set at max DPI and correct Polling.

any ideas?

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 37746
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: COD:AW on XB1 choppy in multiplayer
« Reply #1 on: 10:02 PM - 11/27/14 »
Welcome to the community. You did the right thing of checking if the problem occurs offline vs. online. As it's not happening offline, then, it has to be network related (you XIM4 will function identically between the modes).
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline heitczman

  • Member
  • *
  • Posts: 2
    • View Profile
Re: COD:AW on XB1 choppy in multiplayer
« Reply #2 on: 10:08 PM - 11/27/14 »
I forgot to add though that if I use the controller connected through the XIM4 during multiplayer, its smooth as well. Hence why I checked all of my mouse settings. How could it be my network connection? (which is an above average speed and has not affected any of my XIM3 playing)

Offline king_bugsy

  • Member
  • *
  • Posts: 50
    • View Profile
Re: COD:AW on XB1 choppy in multiplayer
« Reply #3 on: 10:17 PM - 11/27/14 »
I just got my xim 4 today and I am also using a g500. I had a lot of problems earlier trying to find the right sensitivity and fix the choppy feeling until I changed my polling rate to 500 hz and all the problems went away. My xim is running smooth as butter now and feels just as good as pc on ps4. Hope this helps.

Offline amak1

  • MVP
  • *
  • Posts: 5292
    • View Profile
  • Gamertag: Wa2En5emble
Re: COD:AW on XB1 choppy in multiplayer
« Reply #4 on: 01:11 AM - 11/28/14 »
Yea my old g500 is extremely jittery on max dpi and polling so im forced to lower it quite a bit. Ive had it for like 3 years now though and its been abused.

This also happens on my pc with it. at max dpi and poll rate, so i knew it was my mouse. Also ive had a g9x's left click go as well as a razer nagas left click go.

Mouses do go unfortunately, especially if you game a couple hours every night.

I have no idea why it would play correctly offline and not online though, it doesnt make any sense unless the problem wws framerate related and has nothing to do with the mouse or xim.


You definitely need to troubleshoot more.
Ice... 15ml lime cordial... 1 dash angostura bitters... 2 oz 100% agave tequila... top off with sprite or 7 up

Offline Phil Ashio

  • MVP
  • *
  • Posts: 1747
    • View Profile
Re: COD:AW on XB1 choppy in multiplayer
« Reply #5 on: 02:17 AM - 11/28/14 »
I had left click go on two g9xs. Poorly built for sure.
"MW ST1 users are an inferior species and an evolutionary abomination" - On the Origin of Species, Charles Darwin


Admin