XIM Community

[ACTIVE] controller turns off, but mouse/keyboard still work?  (Read 921 times)

Offline Broachster14

  • Member
  • *
  • Posts: 179
    • View Profile
Sometimes when i'm playing on the xbox one the controller will turn off and be unusable, but the mouse and keyboard still work for playing games.  This would be fine except for chat goes through the controller so the mic function no longer works when the controller is off.  When i try to turn it back on, the xbox button on the controller turns on and off 8-10 times and then stays off. Interestingly enough, when I unplug the controller from the xim4, even though the controller is off (or seems to be off) the xbox one says to please reconnect the controller.  I've noticed that occasionally the xbox one will freeze after this happens and a restart is needed.  Any ideas?
« Last Edit: 04:52 PM - 08/22/14 by Aiken_Drum »

Offline Aiken_Drum

  • Support Staff
  • MVP
  • *
  • Posts: 4006
  • You talkin' to me?
    • View Profile
Re: controller turns off, but mouse/keyboard still work?
« Reply #1 on: 04:51 PM - 08/22/14 »
Have you taken the batteries out of the controller?  It's the best way to ensure that the controller is ONLY trying to connect to the XIM, and not getting confused by the presence of the XB1 on wireless.

It also prevents the controller from trying to charge, which can draw too much current for the XIM4's overload protection.


Offline Broachster14

  • Member
  • *
  • Posts: 179
    • View Profile
Yeah the batteries have been out.  Do I need to be pressing buttons on the controller every once in a while in order for the controller to not shut itself off?

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 35574
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
It's a bug we are aware of. Can you tell us if it stops happening if audio isn't plugged in?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline Broachster14

  • Member
  • *
  • Posts: 179
    • View Profile
Thanks for the reply and confirmation of the bug. Will do.

Offline BklynMark

  • Member
  • *
  • Posts: 220
    • View Profile
  • Gamertag: i OwN MLG KiDs
I'm having this issue too even with the beta drop i was sent.  I have to keep unplugging the XIM4 and then plugging it back in.

Offline Aiken_Drum

  • Support Staff
  • MVP
  • *
  • Posts: 4006
  • You talkin' to me?
    • View Profile
Assuming it's working when you read this, can I get you to attach XIM Manager to the XIM4 and then just do whatever until it fails again?  Once that happens, tap/click in the lower-right corner of the Manager window, where there's an invisible button that takes you to a screen with the trace log.  Use the button that looks like overlapping rectangles to copy the contents and then paste into a PM to me.  If it's too big, just paste the last 50-100 lines.

Offline Broachster14

  • Member
  • *
  • Posts: 179
    • View Profile
I'm not sure why sometimes this happens and sometimes it doesn't. Just installed Destiny, and it's doing it again. Bleh.  Any other updates? I'll look into the trace log if it happens again and post it here. Tired of all the issues.

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 35574
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Yes, we have a Beta build out (in the Release Candidates board) that fixes random Xbox One controller disconnects that happen while audio is running.

I suggest you install that build and let us know how it goes.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.