XIM Community

Followed every step and it still doesn't work  (Read 2128 times)

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Followed every step and it still doesn't work
« on: 09:50 PM - 10/18/13 »
I've reset the xim a dozen times and still nothing is working. My mouse is the Logitech MX518, brand new sony nav (with the usb-bt211 dongle) and a brand new shockwave 3 (my ps3 is only 2 weeks old brand new).

First I charged the controller on the ps3 and nav on my pc. I then plugged my shock into the left, nav in the center and dongle into the right as per the instructions and then plugged it into my console. It flashed different colors then about 3 blue flashes then went to solid red. I then unplugged the xim and removed everything from the front.

I then connected xim to my PC and started the latest config manager it connected fine with solid blue light.

I went into the config for COD MW3 and selected the settings I wanted my mouse to have using detect and then the settings for the nav I did manually since detect doesn't work and I used the nav key number codes found in these forums.

Saved and downloaded back to the xim
plugged my shock back into left
mouse into the middle
and dongle on the right

I then plugged the xim back into the the console and hit power, system came on I started the game and when into campaign mode and the only thing working is I can look around by using the mouse. All the buttons on the mouse and nav do nothing except my right mouse button but it does nothing in game. When I press it the xim changes color from red to yellow.

Please someone tell me what is going on. All the set up videos I seen show the xim connecting and working easily.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #1 on: 10:13 PM - 10/18/13 »
To summarize your problems.

1. You receive flashes when XIM is turned on, followed by a solid red light.
2. Only your mouse works, you can move the view in game.
3. Your BT isn't working for your nav
4. The only mouse button that works is rmb and it changes configs to a yellow config.


Alright so addressing these..

1. The three sets of yellow flashes you are seeing indicate that Edge cannot see your device. You get three sets of two flashes each for port 2, three sets of three flashes for port 3. I'm assuming these flashes are related to your bluetooth adapter as your mouse works.

Take a look at page 9 here: http://xim3.com/wp-content/uploads/2012/10/XIM-Edge-User-Manual.pdf

note that you may have to unpair your nav from your ps3 first, unpairing can be done by holding the small reset button down that's located on the back of your nav.

2. Once you get your nav working wirelessly, or infact if you plug your nav in wired to your Edge for now make sure your config is set to joystick. See the pic attached to this post below on how to do this.

3. See 1.

4. See 2. Also, since it sounds like you're using your Edge on ps3 be sure you are selecting the ps3 version of these configs in Xim Manager. See the second attached picture for details, be sure to select your console here when creating the config.

Finally, you said your config color changes to yellow, are you sure it isn't turning green? Green is the ads color that is used to show the user ads is activated. If it does turn yellow check your other config colors, is there a yellow config? If you do have a yellow config what is it's hotkey? Be sure the hotkey isn't your ads activation key, usually right mouse button. See the third image for an example of where that's at.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #2 on: 10:27 PM - 10/18/13 »

1. The three sets of yellow flashes you are seeing indicate that Edge cannot see your device. You get three sets of two flashes each for port 2, three sets of three flashes for port 3. I'm assuming these flashes are related to your bluetooth adapter as your mouse works.

Mouse buttons do not work. The yellow blinks once every time I click my right mouse button. That button is what I have always used as my jump button

Take a look at page 9 here: http://xim3.com/wp-content/uploads/2012/10/XIM-Edge-User-Manual.pdf

note that you may have to unpair your nav from your ps3 first, unpairing can be done by holding the small reset button down that's located on the back of your nav.

I have done this prior to connecting it to the center port. Again shock in left nav in center dongle in right. flashes several colors then a couple blue flashes straight to solid red. I unplugged during solid red

2. Once you get your nav working wirelessly, or infact if you plug your nav in wired to your Edge for now make sure your config is set to joystick. See the pic attached to this post below on how to do this.
I did change from keyboard to joystick in the config

3. See 1.

4. See 2. Also, since it sounds like you're using your Edge on ps3 be sure you are selecting the ps3 version of these configs in Xim Manager. See the second attached picture for details, be sure to select your console here when creating the config.
COD MW2 PS3 shown on the top of the config screen


Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #3 on: 10:56 PM - 10/18/13 »
Mouse buttons do not work. The yellow blinks once every time I click my right mouse button. That button is what I have always used as my jump button

Is the config you are attempting to use the start up config and as a followup is your color set to red? If a different config is selected as your startup config this would explain why your mouse buttons aren't functioning correctly.

I have done this prior to connecting it to the center port. Again shock in left nav in center dongle in right. flashes several colors then a couple blue flashes straight to solid red. I unplugged during solid red

All I can suggest is that you make sure the nav is fully charged, this will take a few hours. See if it's still paired with the ps3 and again unpair accordingly. I've seen another user have unpairing issues as well.

Also, can you please tell me the model number of the BT dongle you are using. If you can get it off the packaging or the receipt that would be most helpful. Please don't pull this information from the manual as we need to verify it's correct.

I did change from keyboard to joystick in the config

Good, this is a common change most users overlook. It seems you've researched well. :)

COD MW2 PS3 shown on the top of the config screen

Thanks for checking, if you were using the wrong console ST the keymap would be incorrect and cause the left and right mouse button to be bound incorrectly.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #4 on: 11:03 PM - 10/18/13 »
I have figured it out. I deleted the installed CODMW3 config and clicked new then added a new set of configs.. All works great!! Only thing to me after turning my mouse on high and my sensitivity on insane I still think it's slow while aiming down sights. Which do I mess with only  sensitivity or both options for Aim down sights setting?

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #5 on: 11:25 PM - 10/18/13 »
Turning around is too slow for me. What is the highest number the xim will allow for hip sensitivity?

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #6 on: 11:29 PM - 10/18/13 »
Great, I'm glad it's now working. If you end up playing multiple games on your XIM I suggest setting up a config cycle key and remember the colors of your configs. Since you use a nav, having a hotkey for each config would not be practical. The cycle key works great for users who have limited buttons. See below

Only thing to me after turning my mouse on high and my sensitivity on insane I still think it's slow while aiming down sights. Which do I mess with only  sensitivity or both options for Aim down sights setting?

Your sensitivity value will depend on your mouse dpi and game played. What mouse dpi were you using again? What game? We recommend mice over 1600 dpi for best performance. Hip is your sensitivity for regular running and gunning and since console shooters tend to slow down your sensitivity when you're aiming we have an ADS sensitivity as well to help with this. Adjust each as necessary.
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #7 on: 11:44 PM - 10/18/13 »
Your sensitivity value will depend on your mouse dpi and game played. What mouse dpi were you using again? What game? We recommend mice over 1600 dpi for best performance. Hip is your sensitivity for regular running and gunning and since console shooters tend to slow down your sensitivity when you're aiming we have an ADS sensitivity as well to help with this. Adjust each as necessary.
I have it turned all the way up to 1600

CODMW3

I have turned up the sensitivity for aim down sights to my liking but I was hoping that turning up the hip sensitivity it would allow me to spin faster while not aiming. I've been a PC FPS player for 15 years and in console it just doesn't look around fast enough for what I'm used to when I go to move or turn around.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 57769
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #8 on: 11:56 PM - 10/18/13 »
Well unfortunately console games have a turn speed limit. It's set by the game developer in each game and it can vary between games. When the turn limit is reached you cannot turn any faster in the game and any additional mouse movement isn't picked up. You will be notified of this by red flashing lights on your Edge, when you see this you should either lower your sensitivity or slow your mouse swipes down. Attempting to move faster than the game allows will result in you wasting mouse surface space and results in a slower and shorter turn. I suggest learning this limit and try to "ride" the turn limit, reaching it during your swipe but not exceeding will give you optimal turns.

This video will actually go over turning on console and if you are a visual learner check it out. It's demonstrated with a XIM3 and the XIM3's black dot indicator is the same as Edges red light flash.


Call of Duty has one of the highest turn speeds on console and aiming from the hip allows for faster turning than aiming from the sight. Generally most players aren't hindered by the turn speed limit of CoD but yes if you're a long time pc gamer accustomed to twitch shooters like Quake you may feel it.

Check your sensitivity levels in Xim Manager for hip and ads. I haven't played CoD in a long time but at 1600 dpi I think a good range is around 35-50 for you. Having the sensitivity too high is not advised as explained in my first paragraph. Also, if you want to adjust on the fly in game you can press start and select on your controller, use the dpad up/down for hip adjustment, dpad left/right for ads adjustment and then start and select to save settings and return to game mode.
« Last Edit: 12:02 AM - 10/19/13 by mist4fun »
Have a problem with your XIM APEX? Find a solution in the XIM APEX Support FAQ
XIM APEX Quick Start Guide   |   XIM Instructional Videos

Offline cromag

  • Member
  • *
  • Posts: 6
    • View Profile
Re: Followed every step and it still doesn't work
« Reply #9 on: 09:14 AM - 10/19/13 »
Thank you all for your help and advice. I tried to hold out with PC but when everyone I play with left PC for console I had not give up PC's.   :-\ I was ready to give it up all together until I found xim cause stick aiming SUCKS!

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 41150
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Re: Followed every step and it still doesn't work
« Reply #10 on: 11:30 AM - 10/19/13 »
If you have access to a higher DPI mouse I'd suggest trying that. For example, at 5700dpi you should be able to turn around within 2" at a XIM Sensitivity of 30. You will still be able to turn around just as fast at 1600dpi, but, your fine aiming will be less stable.
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.