XIM Community

Major Issues with Left 4 Dead - Need some serious help  (Read 3602 times)

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Hey everyone.
I just got my XIM2-Flex yesterday and I am having a hell of a time getting it to work correctly with my favorite game, Left 4 Dead.  The whole reason why i got this was so I could play L4D with a m&k but have come across a few problems that make me want to throw my xbox out my window.

I have tried Tonester's, CEOrko's and xavier_s37's L4D-configs and I get bad results with all 3.  For some reason my crosshairs go left/down when I try to aim left, so I try to correct it and they go left/up.  So it looks like I am making a zig-zag with my crosshairs when i just want to aim left. But heres the funny thing, I thought maybe it was just my xim so I tossed in COD WaW (i never play that game) and used Tonester's COD config and it felt AMAZING! So I know its not my xim.

Here is my setup
19" Widescreen
Logitech G9 Mouse (set to 1800dpi)
Logitech G15 Keyboard
Windows Vista Ultimate x64

Here are my issues
  • L4D Only - Jerky mouse movement.  My crosshairs jump around in game when I make any small movements with my mouse.
  • L4D Only - ZigZag motion (up/down)when trying to aim left or right. I get /\/\/\ when I want -----
  • Works great in COD5 (World at War)
  • Both L4D and COD5 - XIM doesnt track fast mouse movements. My PC tracks it, and according to my XIM the sticks are maxed out but it sure doesnt feel like it because I get faster in game movements with slower mouse movements.  So if there is an enemy behind me, I need to make slow mouse movements to do the 180, I cant whip around because xim doesnt detect that I am trying to hurry and turn.
  • XIMCalibrate does not work for me, just freezes and never detects my XIM

Other than that this thing is great but only tested it with L4D and COD5.  I really want to play L4D with something even close to how COD5 felt.

I am at work right now but I can record a video of the issues I am having if needed.  Any help would be great because I want to keep my XIM but cant if it wont work for my fav games. Thanks!!
« Last Edit: 09:18 AM - 03/19/09 by Omen »

Offline Snow

  • Member
  • *
  • Posts: 372
  • Master of Radiation
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #1 on: 09:12 AM - 03/19/09 »
From the sounds of it, it seems like you haven't set your deadzone type. I'm guessing L4D had a square deadzone. COD4/5 have circle. If you left the type on circle, it will definitely act weird in a square deadzone game and will jump all over the place.
"Evil will always triumph, because Good is dumb" - Dark Helmet

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #2 on: 09:17 AM - 03/19/09 »
I manually set my deadzone to square when trying L4D and circle for COD5 (i followed both of tonesters configs)

I also forgot to mention I am on Vista x64 and calibration tool will not run for me...well it runs but locks up on:



It is hooked up because I can play games on my xbox with my m&k.
My XIMCalibrate.ini is as follows :(

[Calibration]
OffsetRX=0
OffsetRY=0
OffsetLX=0
OffsetLY=0
OffsetRT=0
OffsetLT=0
RatioRX=1.
RatioRY=1.
RatioLX=1.
RatioLY=1.
RatioRT=1.
RatioLT=1.
« Last Edit: 09:27 AM - 03/19/09 by Omen »

Offline Snow

  • Member
  • *
  • Posts: 372
  • Master of Radiation
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #3 on: 09:56 AM - 03/19/09 »
Ok, I may know what happened, assuming installation works roughly the same on Vista as it does XP. It did that on both my xp machines. I would install the software and drivers, however it would still say that the xim wasn't detected and would hang on calibration. I redid everything: I plugged in the 2 cables, then installed the software. By default, when you plug the cables in for the first time (of after uninstalling a bad install), the "new hardware found" window pops open. All I did, was run the installer until it got to the calibration bit, then I clicked on the "hardware found" window and manually installed the driver. On one machine it still opened even after the driver was installed by the XIM installer. Anyway, as soon as I located the driver and it was installed, the calibration tool then completed and my XIM was ready to go.

The other problem with Vista is the stupid driver signing thing. There are a few threads about it in the forum. However, that shouldn't affect calibration. You'd have a seperate notification about a problem with the driver, I believe.

I hope this helps.
"Evil will always triumph, because Good is dumb" - Dark Helmet

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #4 on: 10:55 AM - 03/19/09 »
Thanks for the replies Snow.  I had to install that ReadyDriver app or whatever the name of it was and the drivers installed but still had no luck with calibration. Do you think since I couldnt run XIMCalibrate.exe that this is why my L4D sucks so bad? I kinda wanna leave work early to try out your suggestions.

I will try uninstalling everything tonight and giving it another shot.  If that doesnt work I will try it on my media center by my TV and if THAT doesnt work I will try my laptop. and if all else fails I will have to ask dereck for a refund :(

Offline Snow

  • Member
  • *
  • Posts: 372
  • Master of Radiation
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #5 on: 11:55 AM - 03/19/09 »
We'll get you up and running. Once you successfully calibrate, then you will be fine. But yes, do uninstall everything first tonight. Then like I said, plug in the grey cable. Windows is supposed to automatically install, but may not. If the new hardware found window is open, leave it. Fire up the XIM360 installer and follow the instructions. Once it gets to calibrating and hangs, manually install the driver (while the installer is still running) and calibration should then immediately complete. As I said, this is the only way I could get it to work on mine. I'll be checking this thread today a few times this evening to see where you get to.
"Evil will always triumph, because Good is dumb" - Dark Helmet

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #6 on: 11:59 AM - 03/19/09 »
thanks man, i will be home to try all of this around 6pm EST. I will post an update here...pretty excited cuz i thought all was lost and thats just how left 4 dead played.

Offline Zardoz

  • Member
  • *
  • Posts: 27
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #7 on: 12:24 PM - 03/19/09 »
You might have to uninstall the driver manually.  Shouldn't, but might.  I did, but then I hadn't dealt with the driver signing issue properly either.
Here's a thread that might help, see the second to last post:  http://xim3.com/community/index.php?topic=2043.0

Offline AngelsAdvance

  • Member
  • *
  • Posts: 159
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #8 on: 12:44 PM - 03/19/09 »
I had Vista 64 bit as well on my laptop and could never get XIM calibrate to work.  But I had already calibrated it on my XP PC and it seemed to work fine on my Laptop so I never said anything.

As long as your in game settings and config is setup correctly then your issue is either with
A. your calibration... Try to manually uninstall all drivers and files related to XIM then re-install.
or
B. your perception... Maybe you are expecting too much?  There are some games which are very compatible with the XIM (allowing individual X / Y Sensitivities, little or no acceleration, and circular deadzones)... Then there are some games like Left4Dead that do really funky things (whacko acceleration rates, X/Y sensitivities that also change acceleration, and odd deadzones like RESIDENT EVIL 5... those bitches)

That being said... I think it is your XIM calibrate... Because I play L4D with the XIM and love it.  I'm a twitch gamer and the profile I have setup is perfect for small movements that snap to positions.  I have a higher translation component with lower sensitivity to combat acceleration.  oh yeah, and no Zig Zags...

=)

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #9 on: 01:27 PM - 03/19/09 »
I will try hooking it up to my media server in my living room (XP Pro SP3 x86) and see if I can get it to work.  As for expecting too much, if it feels anything like COD5 as is, without calibration, then im impressed. Like I said, I will try and make a couple demo videos if I cant get this calibration to work.  i am running stock settings so i am really really reeeeaalllyy hoping thats all that is wrong.

I am also wondering if there is a console command I can apply to "hack" L4D and disable any acceleration because you can hack your profile to spawn more common infected, tanks, witches etc so I hope there is a command to disable acceleration which would make the game even better!!  there is an app out there called the left4deadmodtool that lets you mess with the console game as if it were a pc game.

Offline AngelsAdvance

  • Member
  • *
  • Posts: 159
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #10 on: 02:26 PM - 03/19/09 »
I am also wondering if there is a console command I can apply to "hack" L4D and disable any acceleration because you can hack your profile to spawn more common infected, tanks, witches etc so I hope there is a command to disable acceleration which would make the game even better!!  there is an app out there called the left4deadmodtool that lets you mess with the console game as if it were a pc game.
What do you mean console command?  I think the PC version enables console and cheat / hack entries however I have never heard of this for XBOX.  If you have such a hack I really hope you will share it with me =)

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #11 on: 02:37 PM - 03/19/09 »
http://www.youtube.com/watch?v=5BZ5Z6tP530
http://www.youtube.com/watch?v=NgJ5VxTgT_U

I have played around with this a few times (you have to clear your cache) but before the patch you could actually bind controller buttons to perform console commands such as spawn entities, remove props in game, spawn boxes and build little forts, infinite ammo/health, spawn multiple infected, no clip (fly/fly through walls) IN MULTIPLAYER and freak people out, but i found out about this post patch. all they did was basically set up a button so when you pressed it, it would send a text command to the console like "noclip"  or "z_spawn tank" or "z_spawn witch" etc. what I would love to see is a command to disable acceleration so we dont have to deal with that.  ---- holy crap, i just searched the l4d wiki and there is an option for that!

joy_accelmax : 1
joy_accelscale : 0
joy_response_look : 0 : 'Look' stick response mode: 0=Default, 1=Acceleration Promotion

Full list
http://left4dead.wikia.com/wiki/Complete_list_of_console_commands

ctrl+f and search for "accel" there is actually a few referencing it. i would love to bind an unused button to disable joy_accel

you can get the tool from the video page on youtube...i tried to post a link to the vid but it made it display here. http://tinyurl.com/l4dmod
« Last Edit: 02:44 PM - 03/19/09 by Omen »

Offline AngelsAdvance

  • Member
  • *
  • Posts: 159
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #12 on: 02:55 PM - 03/19/09 »
+rep just for giving me a glimmer of hope for disabling acceleration in that game.  I will go home and see if it works tonight.  So post-patch none of the console commands worked or just the ones that spawned zombies etc?
I wonder if clearing cache, running console command, and then updating the game again would keep that setting at no acceleration or what.

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #13 on: 03:15 PM - 03/19/09 »
your guess is as good as mine but id love to get in touch with the authors of that tool to see if they can add some options for disabling this @#$% joystick accel and thanks for the rep!

Offline Omen

  • Member
  • *
  • Posts: 41
    • View Profile
Re: Major Issues with Left 4 Dead - Need some serious help
« Reply #14 on: 03:38 PM - 03/19/09 »
turn out it was my ximconfiguration. i was able to run that app and not it plays a LOT better but I now see what you guys are saying about this acceleration!!! gggrrrrrr  i hate how you slide your mouse at a steady pace but it speeds up on its own :(