XIM Community

Xim Edge - Not working on PS3 [Update - 360 controller fixed it]  (Read 3335 times)

Offline antithesis

  • MVP
  • *
  • Posts: 9961
    • View Profile
    • Mod Squad
My Xim Edge arrived a week ago and I've spent a solid 4 or 5 hours playing with the configuration settings on PC over the last couple of days.

The unit has no problem detecting key or mouse buttons on a number of different mice and keyboards when connected to PC. Everything looked to be working perfectly until I tried connecting it to a PS3 - when connected it goes into a power cycle, lights up my mouse and keyboard, then reboots...rinse and repeat.

I've tried the Edge with a Razer Deathadder, Razer Lachesis, Razer Orochi, Logitech G300, Roccat Pyra and Roccat Kova+, as well as a Logitech G19, Logitech G13 and ZBoard Fang. I have 3 PS3's (60GB Fatty, 80GB Fatty, 120GB Slim), 4 DualShocks and 3 Sixaxis original PS3 controllers and tried 5 USB cables...no combination of console + mouse + keyboard + controller + USB port + USB cable + Xim Edge port is working.

At one point after hard-resetting my PS3 controller the Xim Edge managed to crap itself. A hard-reset and re-flash fixed that, but I've now lost all of my configs... :'(

I've upgraded to the latest Xim Edge Firmware and use the latest PS3 Firmware. Rebooting the PS3 makes no difference. Having a mouse, Dualshock and KB plugged in, or not, makes no difference - I get the same sequence of lights. Plug it back into the PC via Xim Manager and everything looks fine and dandy.

The last thing the Edge does is hold red for about 3 seconds, then flashes orange 2 or 3 times before power cycling which seems to indicate a USB port problem or device detection problem. As stated above, I've tried numerous mice, keyboards, cables, controllers and ports...none of them work.

Am I doing something wrong or do I have a dud unit on my hands? ??? I've used any combination of the same PS3s, mice, keyboards and cables with a Xim3 with zero problems. I don't have the GTMax plugged into the Xim Edge, it's the only device connected and rumble is disabled.

The only difference is the wired 360 controller vs DualShock or the Xim Edge failing to detect it. As mentioned, it makes no difference if m+kb+DS is plugged in or not and I have tried 7 original PS3 controllers, all fully charged.

I'm out of ideas here...is there a specific sequence of colours I can use to help troubleshoot the problem? Does the DualShock need to be hard-reset before plugging into the Edge (I tried that)? There's no troubleshooting info in the Xim Edge Manual for PS3 so I'm unsure if I'm missing a step.

I suspect it has a dud USB port, but how can I test it? Configuring via PC doesn't use the USB ports and the mouse and kb do light up for a second or two in any Xim Edge port but the Edge reboots no matter what I do.

I've even tried connecting it to a powered USB hub connected to the PS3. The Xim Edge reboots once, then stays blue, but fails to do anything and doesn't detect any devices.

Little help!?!

[update] As a last desperate attempt, plugging the 360 controller in and using the GTMax is working, but that's besides the point...sigh.

It has something to do with the PS3 controller and I've tried all 7. What's the secret missing step?

[update 2.0] Success! DualShock / Sixaxis is now working AFTER the Xim Edge detected the 360 controller. None of the DS/6-Axis controllers worked previously. Don't know why - it all seemed idiot-proof and I used the exact same procedure for the 360 and PS3 controllers.

« Last Edit: 08:17 AM - 07/25/12 by antithesis »

Official Australian distributor for XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline Threewheels

  • MVP
  • *
  • Posts: 2734
    • View Profile
wow, good job on figuring that out. 

So after you connected it to the 360 controller, it will now sync properly with the PS3 controller by itself (don't have to use the 360 controller anymore)?

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 37843
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Ok, let's back up, you are saying things are working now, but, you kept getting an infinite sequence of red-green-blue? If so, we need you at the latest RC Tester firmware which has a change in there that makes it "less-easy" to corrupt your Configs.

Also, all these devices worked?: Razer Deathadder, Razer Lachesis, Razer Orochi, Logitech G300, Roccat Pyra and Roccat Kova+, as well as a Logitech G19, Logitech G13 and ZBoard Fang
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline antithesis

  • MVP
  • *
  • Posts: 9961
    • View Profile
    • Mod Squad
wow, good job on figuring that out. 

So after you connected it to the 360 controller, it will now sync properly with the PS3 controller by itself (don't have to use the 360 controller anymore)?

That's right Wheels. I'll do some more testing to confirm, but as soon the Edge detected the 360 controller just once, it subsequently detects the PS3 controller. I'm clueless as to why ???

Ok, let's back up, you are saying things are working now, but, you kept getting an infinite sequence of red-green-blue? If so, we need you at the latest RC Tester firmware which has a change in there that makes it "less-easy" to corrupt your Configs.

Also, all these devices worked?: Razer Deathadder, Razer Lachesis, Razer Orochi, Logitech G300, Roccat Pyra and Roccat Kova+, as well as a Logitech G19, Logitech G13 and ZBoard Fang
OBs, the R>G>B sequence only happened once, more than likely because I interrupted the boot-up.

Every other time, the Edge would boot-up normally, get to the Red stage, detect the mouse & kb for 2-3 seconds, then flash Orange 2 or 3 times (it flashes quickly, so I wasn't certain), then reboot and repeat.

Based on the flashing Orange sequence, I looked at the FAQ and nailed it down to either a USB port problem or device detection problem with the PS3 controller. Given the Edge would momentarily detect the m+kb in any USB port combination, I figured it must be the Dualshock / Sixaxis failing to detect, which ultimately seemed to be correct.

I initially tested the Edge with all devices and couldn't get any to work, thanks to the PS3 controller detection issue. I've subsequently tested just the Kova+, G13 and Fang...no problems to report. I can easily test the Pyra, Orochi, Lachesis, Deathadder, G300 and G19 and will do so today.

I've used the Orochi for close to a year with the Xim3 and all buttons for the Pyra, Kova+ and G300 detected correctly on the PC and Xim3, including the Easy Shift function. I'll confirm the rest and update the thread.

Happy to test out the RC - I was in the group at one stage but currently don't have access.
« Last Edit: 05:28 PM - 07/25/12 by antithesis »

Official Australian distributor for XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 37843
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
Please reapply for RC Tester and I'd definitely appreciate having all the hardware coverage if you have the time.

Also, the quick yellow flash means Edge is writing itself (meaning, it's unsafe to unplug it). What was happening is Edge wasn't able to talk to your controller and so it started entering PC-Mode.

I'll update the manual to include the rapid flash sequence.

Get the most out of your XIM APEX, read the XIM APEX Support FAQ.

Offline antithesis

  • MVP
  • *
  • Posts: 9961
    • View Profile
    • Mod Squad
Please reapply for RC Tester and I'd definitely appreciate having all the hardware coverage if you have the time.

Also, the quick yellow flash means Edge is writing itself (meaning, it's unsafe to unplug it). What was happening is Edge wasn't able to talk to your controller and so it started entering PC-Mode.

I'll update the manual to include the rapid flash sequence.


No worries, happy to help. If it wasn't for your toys, I wouldn't be playing FPS / 3PS games on my consoles :D

Interesting that it was entering PC-Mode. When plugged into the USB hub (Roccat Apuri) > PS3 it seemed to succeed (solid blue lights). If plugged directly into the PS3, it rebooted.

Official Australian distributor for XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline OBsIV

  • Administrator
  • MVP
  • *
  • Posts: 37843
  • It's obsessive.
    • View Profile
    • OBsIV's Blog
If Edge is rebooting and entering PC-Mode, it means that it wasn't able to talk to your PS3 controller. What did you say was the solution again?
Get the most out of your XIM APEX, read the XIM APEX Support FAQ.