XIM Community

[ACTIVE] XIM Apex Firmware Update  (Read 62 times)

Offline Knives

  • Member
  • *
  • Posts: 2
    • View Profile
[ACTIVE] XIM Apex Firmware Update
« on: 02:59 PM - 06/15/22 »
I am trying to download the latest firmware updates for my XIM Apex. The light won't stay a solid blue, it is slowly flashing. The firmware tool is simply telling me to make sure there are no devices connected to it (there aren't) and is displaying a solid blue light (it refuses to do that). Feel like I bought a piece of junk that is no longer supported.

I have tried holding down the button and attempted a factor reset as well. Nothing works, I just get the same error mesage.

The worst part is it's an old purchase, so I am guessing I can't even exchange it. Can anyone help?
« Last Edit: 04:36 PM - 06/15/22 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58817
    • View Profile
Re: XIM Apex Firmware Update
« Reply #1 on: 04:36 PM - 06/15/22 »
Welcome to the community. This is a common problem some people have. The button should be held before plugging APEX into the PC and released only after the light is solid blue.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos