XIM Community

[RESOLVED] Xim Apex isn't working  (Read 198 times)

Offline Bakbanaan

  • Member
  • *
  • Posts: 43
    • View Profile
  • PSN ID: xzoR93
[RESOLVED] Xim Apex isn't working
« on: 04:09 PM - 06/09/22 »
Hi,

Recently my Apex isn't working properly. My mouse and keyboard aren't reacting on my Xbox. I've used Xim Link in tandem from the start.

When i look in the manager app, i only see one icon at the top, stating xim transfer cable. Usually, when it works, it shows two icons on top (out of 3)

I've tried the following;

- reconnecting every cable
- a factory reset

To no avail.

The led on the Apex is working properly. Also, the controller is buzzing when i connect it to the hub.

I would greatly appreciate if you guys could help my out.

Thank you!
« Last Edit: 04:34 PM - 06/30/22 by mist4fun »

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58848
    • View Profile
Re: Xim Apex isn't working
« Reply #1 on: 04:30 PM - 06/09/22 »
With the peripherals not displaying at the top of Manager it may help to verify the hub is still working. Do your peripherals work while connected to the hub when the hub is attached to a PC directly without APEX?
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline Bakbanaan

  • Member
  • *
  • Posts: 43
    • View Profile
  • PSN ID: xzoR93
Re: [ACTIVE] Xim Apex isn't working
« Reply #2 on: 09:53 AM - 06/10/22 »
Just to be sure. Im just plugging in the hub into a USB port to see what happens? And should i retain the xim link or plug in my keyboard and mouse separately as a test? As of now, port 1 is empty, port 2 is the cable for the link and port 3 is for the controller.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58848
    • View Profile
Re: [ACTIVE] Xim Apex isn't working
« Reply #3 on: 04:23 PM - 06/10/22 »
The test is just to see if the hub works with your peripherals and PC, not APEX or games.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline Bakbanaan

  • Member
  • *
  • Posts: 43
    • View Profile
  • PSN ID: xzoR93
Re: [ACTIVE] Xim Apex isn't working
« Reply #4 on: 08:49 AM - 06/12/22 »
Plugged the hub in, it was powered, and my mouse and keyboard worked fine.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58848
    • View Profile
Re: [ACTIVE] Xim Apex isn't working
« Reply #5 on: 09:21 AM - 06/13/22 »
That's good considering APEX doesn't see any device on the hub while connected to APEX.

Next we should check if APEX's port is able to power and identify devices with direct connection. Try individually connecting your controller or peripherals directly to APEX. They should not work correctly but they should power on and display a device icon at the top of Manager.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline Bakbanaan

  • Member
  • *
  • Posts: 43
    • View Profile
  • PSN ID: xzoR93
Re: [ACTIVE] Xim Apex isn't working
« Reply #6 on: 12:19 PM - 06/14/22 »
My controller isn't showing up in the app. My mouse and keyboard (as a connector, since it's a dongle) are. Controller is vibrating however when i plug it in.

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58848
    • View Profile
Re: [ACTIVE] Xim Apex isn't working
« Reply #7 on: 04:34 PM - 06/14/22 »
Testing other data cables with the controller may help. You also may need to press the controller guide button. These tests should be done without the transfer cable until the problem is fixed.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos

Offline Bakbanaan

  • Member
  • *
  • Posts: 43
    • View Profile
  • PSN ID: xzoR93
Re: [ACTIVE] Xim Apex isn't working
« Reply #8 on: 03:45 PM - 06/30/22 »
Sorry for my late reply, but i was ill for a while.

A cable change did the trick, i think. I experienced no problems after. That was embarrassingly easy. Thank you for your help!

Offline mist4fun

  • Global Moderator
  • MVP
  • *
  • Posts: 58848
    • View Profile
Re: [ACTIVE] Xim Apex isn't working
« Reply #9 on: 04:34 PM - 06/30/22 »
No worries, it's good to hear that it's working again.
Have a problem with your XIM? Find a solution
NEXUS Support FAQ | APEX Support FAQ | XIM4 Support FAQ | Instructional Videos


Admin