XIM Community

Beloader doesnt work anymore  (Read 397 times)

Offline Unknown45

  • Member
  • *
  • Posts: 10
    • View Profile
Beloader doesnt work anymore
« on: 04:16 PM - 06/05/22 »
Hello,

I have the following problem...

I'm following this video right now

https://www.youtube.com/watch?v=XcRW0_jpDPw&t=313s

but fail when trying to connect the beloader to the PC.

If I plug the beloader into the PC without pressing the button = nothing happens except a noise from my PC.
The loader doesn't even light up anymore.

When I plug the loader into the PC together with the button = I hear a noise from my PC again and the beloader just lights up white.

But I don't see it in the drive with either option and no folder opens when I put it in.

When I got the beloader back then and tested it, everything worked without any problems, but now the problems mentioned above occur some time later.

What can I do?

I have the very old one from the very first release and the new one (beloader)
So the problem really shouldn't be the loader

Best Regards,

« Last Edit: 05:48 PM - 06/05/22 by Unknown45 »

Offline Der-libo

  • Member
  • *
  • Posts: 12
    • View Profile
  • Gamertag: Derlibooo
  • PSN ID: Libooo2019
Re: Beloader doesnt work anymore
« Reply #1 on: 02:37 PM - 06/18/22 »
Ive got the same problem nice wenn someone can help us :)

Offline antithesis

  • MVP
  • *
  • Posts: 13942
    • View Profile
    • Mod Squad
Re: Beloader doesnt work anymore
« Reply #2 on: 03:13 PM - 06/18/22 »
Beloader support is provided at https://beloader.com.

Official Australian distributor for
XIM NEXUS, XIM APEX, Titan One & Titan Two at Mod Squad
XIM APEX demos on Twitch and YouTube. Follow Twitter for live stream alerts

Offline AMG

  • MVP
  • *
  • Posts: 2974
  • Gamer - Audiophile - Coder
    • View Profile
Re: Beloader doesnt work anymore
« Reply #3 on: 11:48 AM - 06/19/22 »
I had two Beloaders, got sick of its finnicky performance, tried everything got sick of it, this coming from a very techie guy get rid of it.

Thanks to apex_vip got PSRC on my Rasberry Pi, plug it forgot it... literatelly, to the point where I moved temporatelly far away, took my PS5, XIM and peripherials with me - but forgot the raspberry pi XD.

Fortunatelly I find one on an local electronic store and build a second PSRC module. - ZERO issues, no lag, closest to play native.

OP about your issues sorry, that's sound an issue related to network handkshake.

Before blameming XIM, try by plug in PS4 controller directly to Beloader first and start to troubleshooting from there. Make sure you are running the last firmware, or reflash it.

I don't fellas, I know was with good intentions Od1n put the tutorials for Beloader to help out owners, but miscalculated now XIM forum looks more like a Beloader Support.

Not putting on Od1n, you all belaoder owners PLEASE understand, if you have an issue with Beloader, go to Beloader support, posting belaoder support related threads over and over, is killing XIM community interaction and taking off Beloader brand the responsability of support its device as they should.

Beloader doesn't sees XIM diferently than any other third party controller or even an official discontinued PS3 / PS4 device.
« Last Edit: 12:06 PM - 06/19/22 by AMG »