XIM Community

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Agathon

Pages: [1]
1
XIM Link / Newly random disconnects?
« on: 09:22 AM - 04/12/20 »
Hey all,
I've had Link set up for a really long time and never had any problems. In the past few days, I've started to get all kinds of random disconnects / XIM Apex not detected / etc. Nothing has changed at all as far as software, firmware versions, or anything. I haven't done any updates since this started happening. Any idea what it could be? It will randomly reconnect and doesn't seem to matter what I do. I've tried different usb ports on both my PC and on the xbox and nothing changes it.

Have any of your Belkin cables started "going bad"? I have no idea where the fault is. I don't know if it's with my Xim Apex or with the Belkin cable.

2
Game Support / SW Battlefront 2?
« on: 01:34 PM - 08/08/18 »
I know many of you probably don't play this anymore but I recently started and although it's playable, I'm having a lot of issues with the ST. Maybe my settings are off, I don't know. I get a tremendous amount of input lag randomly though - it spikes occasionally and makes me unable to control the character briefly.

What sense/synchronize/smoothing do you guys have?

Thank you.

3
Game Support / War Thunder - Xbox One?
« on: 09:43 PM - 06/22/18 »
Any plans for support of this game? I use to play this on PC and just noticed it's come out on Xbox. Would love to play it again with a Xim!

Edit: I found another post on this topic which was answered saying no support. Sorry to make a repeat of the same question!

4
Hi,
I heard that using XIMCommander and an Easy-transfer cable, you would be able to bind both sticks to the keyboard. Can anyone tell me how to do this?

I've got everything set up but in XIMCommander I don't really see how to bind anything.

Thanks

5
Hey guys,
I finally got my Xim3 tonight (ordered last month on the 23rd, FEDEX ground is slow! :( ) and it seems great but I'm having a few issues. First, I've watched the various tutorials and everything and I can't seem to figure out what's wrong here. I'm using the  MW3 smart translator with my Razer Naga Epic (1800DPI) and the movement seems to be very jumpy sometimes. It's a bit hard to make subtle movements and kind of skips around unless I'm doing a larger move..

Also, my in-game sensitivity is set at 10 like the videos suggest but I have to put my Xim sensitivity SUPER high (like, 280-350) otherwise it just turns way too slow. That can't be normal, can it? How should I go about fixing this?

Thanks in advance! I have to go for a while but I'll check this thread later. I hope someone can help me out.

Pages: [1]
Admin