XIM Community

General Category => Technical Support => Topic started by: Zeigat on 08:30 AM - 10/10/21

Title: [ACTIVE] PS4 Xim4 Apex Help
Post by: Zeigat on 08:30 AM - 10/10/21
Hey there community

For the past few days I've been having alot of trouble getting my Xim4 to work, I've had a Xim for a few years now so it's not like I don't know how to troubleshoot it, I've done everything tested every port, changed the communication method, gotten new cables, updated the firmware, used different USB hubs, literally I've tried it all.

I own 2 xim4s Apex and neither of them respond, the issue is both xim4 start up and just stay in red, they don't respond to any input at all like it used to, in the app I can see everything connected except the PS4 but I'm not sure if that's an issue but I'm starting to think it is, I got this PS4 a month ago and for some reason the xim4 doesn't work in it, am I out of luck?  Its an old gen PS4, looks like the first model not sure if that matters at all.


Any help would be appreciated.
Title: Re: PS4 Xim4 Apex Help
Post by: Zeigat on 08:32 AM - 10/10/21
To add to my post, I've also gotten new Ps4 controllers.
Title: Re: PS4 Xim4 Apex Help
Post by: OBsIV on 04:34 PM - 10/10/21
Welcome to the community. Normally issues like this are due to a bad cable that is connecting your controller to XIM or a bad USB port on the controller itself. But you are saying that this exact setup always worked and now it doesn't?
Title: Re: [ACTIVE] PS4 Xim4 Apex Help
Post by: Zeigat on 08:12 PM - 10/10/21
When I connect the controller directly into the xim4 the remote turns off and it starts glowing yellow like it's charging, I've managed to get the remote to act this way with the hub aswell but it doesn't turn on no matter what, my second controller is a wired mini and that one literally doesn't do anything but it works fine by itself.

Title: Re: [ACTIVE] PS4 Xim4 Apex Help
Post by: mist4fun on 09:05 AM - 10/11/21
The wired mini isn't manufactured by the console maker so it's not supported by APEX.

Your other controller should be working though. The yellow light is normal, the controller will show a yellow light when charging then the light may turn off. Connect the controller directly to the console to charge while APEX and hub are disconnected to allow it to charge before using it with APEX again.

If this still happens after charging then it would be useful to know if the controller can initialize with APEX, either while connected to the hub or while using direct connection to APEX without the hub.

To do this, Reconnect APEX to the console with everything attached to the hub while watching APEX's startup light sequence. Do you see 4 green lights during this sequence? For reference the startup light sequence should look similar to this:

red, green, blue
red
green, green, green, green
red

If you do not see 4 green lights at startup disconnect the hub then reconnect APEX to the console with only the controller attached to APEX while looking for the green lights mentioned before.
Title: Re: [ACTIVE] PS4 Xim4 Apex Help
Post by: Zeigat on 12:19 PM - 10/12/21
No green lights, do you think it might be a controller issue then?
Title: Re: [ACTIVE] PS4 Xim4 Apex Help
Post by: mist4fun on 04:30 PM - 10/12/21
That's a problem but it's more likely to be caused by the controller cable. If you have spare data cables around testing these with the controller may help. When you test next try using the controller directly with APEX while the hub is disconnected. If you have the 4 green lights remember this then repeat the test with the hub. It would be useful to know if you have the green lights without the hub but not while the hub is connected.