XIM Community

General Category => Technical Support => Topic started by: yvngPabloEsco on 08:43 AM - 10/09/21

Title: [RESOLVED] Strange Problem with my XIM Apex
Post by: yvngPabloEsco on 08:43 AM - 10/09/21
For the last week or so my xim apex has been practically unusable. Everything starts up fine, but as soon as I make any input my console starts glitching and opening the recording tab to the point that I have to completely unplug my Xbox for it to unfreeze/start again. Iíve factory reset and updated the firmware to the latest beta update for the series controllers because I have an elite controller 2 and itís still happening.
Title: Re: Strange Problem with my XIM Apex
Post by: yvngPabloEsco on 08:50 AM - 10/09/21
After looking through other threads I want to add that my controller was not connected to the xim during the update.
Title: Re: Strange Problem with my XIM Apex
Post by: jmongoose on 09:17 AM - 10/09/21
Having the same issue with g604. Spamming screen shot to Xbox. No movement.
Title: Re: Strange Problem with my XIM Apex
Post by: OBsIV on 04:31 PM - 10/10/21
Can you please upgrade to our latest Beta firmware here and let us know if the problem still exists?: http://xim.tech/beta

Also, let us know the type of Xbox console and controller you are using.
Title: Re: [ACTIVE] Strange Problem with my XIM Apex
Post by: yvngPabloEsco on 03:17 AM - 10/12/21
I downloaded the beta firmware and manager and the problem is still happening. Both with a series 1 and 2 elite controller on the Xbox one X.
Title: Re: [ACTIVE] Strange Problem with my XIM Apex
Post by: mist4fun on 11:32 AM - 10/12/21
There's been another beta update today to address this. After downloading the update it may be necessary to press the guide button to initialize the controller after startup.

If you would like to test our latest beta please visit the link below. Please read the instructions on the download pages. Feedback in the beta section of the forum is appreciated.

https://xim.tech/beta
Title: Re: [ACTIVE] Strange Problem with my XIM Apex
Post by: LLEVIATHANN on 02:21 PM - 10/12/21
There's been another beta update today to address this. After downloading the update it may be necessary to press the guide button to initialize the controller after startup.

If you would like to test our latest beta please visit the link below. Please read the instructions on the download pages. Feedback in the beta section of the forum is appreciated.

https://xim.tech/beta
New beta fixed it for me. Thank you guys.
Title: Re: [RESOLVED] Strange Problem with my XIM Apex
Post by: mist4fun on 04:37 PM - 10/12/21
That's good to hear, thanks for updating your thread.